MacBook Pro (Penryn) MagSafe PSU problem

Discussion in 'MacBook Pro' started by Artmuzz, Jan 27, 2009.

  1. Artmuzz macrumors 6502

    Joined:
    Jun 17, 2008
    #1
    Hi,

    Last night I took my Macbook Pro out of its bag and plugged in the MagSafe Power Supply. When I switched it on at the mains at the wall the light on the plug that plugs into my MacBook Pro would not go on. I quicky switched it off and on again at the mains and then the light came on showing amber (because its charging).

    After using my MacBook Pro, I shut down and left it to charge. However after 5 minutes the light went off again on the plug so I tried to move the wire and while I was moving it I seen that the light on the plug was flickering green and amber quickly. Also when I put my ears to the MagSafe PSU box I hear a buzzing sound while moving the wires and the sound goes in sync with the flickering of the light on the plug.:confused:

    I then booted my MacBook Pro and once it booted up the light on the plug came back on. After that I had no more problems and even today the problem have gone away so far.

    Does anyone know what was or is the problem?

    Please advise

    Art
     
  2. Quu macrumors 68020

    Quu

    Joined:
    Apr 2, 2007
    #2
    Sounds like the cable is coming loose from the connector at the end and the live wires are making and losing contact with the connector as you move it around.

    I've seen this a few times with Mag Safes and it has even happened on my own machine however I've been reluctant to replace my own charger as I'm planning to buy a new machine.

    If you still have Apple Care give them a call and maybe they will replace it (They should)
     
  3. Artmuzz thread starter macrumors 6502

    Joined:
    Jun 17, 2008
    #3
    I've still got 5 months left of my 1 year warranty. Will I still get a free replacement?


    Art
     

Share This Page