MacBook Pro & Photobooth

Discussion in 'MacBook Pro' started by queshy, Jul 20, 2007.

  1. queshy macrumors 68040

    queshy

    Joined:
    Apr 2, 2005
    #1
    So everytime I launch photobooth, the picture that it displays is green for like one second then it switches to the camera. My iMac doesn't behave like that...anyone else having a similar issue? Thanks.
     
  2. Jim Campbell macrumors 6502a

    Jim Campbell

    Joined:
    Dec 6, 2006
    Location:
    A World of my Own; UK
    #2
    I think it's a power management thing - being connected to the mains electricity, the iMac doesn't need to power the iSight down completely, but for battery conservation, the MB/MBP does.

    I don't know this for sure, but since the problem with Photobooth on laptops getting stuck on a green screen is clearly identified by Apple as being an issue with the Power Management Unit, it seems like a fairly logical deduction.

    Cheers!

    Jim
     
  3. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #3
    Don't have this problem - mine starts black then adjusts brightness and its there within a split second.
     
  4. amusiccale macrumors 6502

    Joined:
    Jun 5, 2007
    #4
    Are you under, say, fluorescent lighting? I am guessing what you are seeing is the camera's default white balance and light level for (on mine, far less than second) a moment before it adjusts to your light conditions. Try it outdoors and see if it's different there (perhaps almost white)
     
  5. queshy thread starter macrumors 68040

    queshy

    Joined:
    Apr 2, 2005
    #5
    no fluorescent lighting but it happens for like 1/3 of a split second,.,,the whole second is an exageration. so is this normal?
     
  6. amusiccale macrumors 6502

    Joined:
    Jun 5, 2007
    #6
    Mine is green briefly before displaying a picture, but it's obviously moving from whatever setting it's at to adjust to the ambient light. I would say unless it's a locked green screen, it's just a result of wherever the hardware or software parks the camera at by default until you power it up.
     
  7. queshy thread starter macrumors 68040

    queshy

    Joined:
    Apr 2, 2005
    #7
    oh ok, great. I'd say around 50% of the time I start photobooth I get a green screen briefly before displaying a picture. I just want to be absolutely sure my mbp is not defective.
     

Share This Page