MacBook Pro - problem joining wireless network

Discussion in 'MacBook Pro' started by killmoms, Feb 17, 2007.

  1. killmoms macrumors 68040


    Jun 23, 2003
    Washington, DC
    Okay, so I have a WiFi network in my apartment, with WEP Password encryption. I have a Mac Pro and a PowerBook connected to it successfully, no problems. My friend is trying to connect his MacBook Pro, and it refuses to connect. He came over here before and connected to it when it was on WPA mode, but I changed the security setting since then. So I deleted the keychain entry for my network, I even deleted his Airport preferences and rebooted, but all to no avail. Where my Mac Pro connects instantly, the MacBook times out and then gives the unhelpful, non-descript error "There was an error joining the AirPort network [name]." Clicking Try Again just nets the same error after a few seconds.

    Any ideas? :confused:

    Just checked system.log in the Console and found this line:

    Feb 17  21:53:00 rian-kountzs-computer /System/Library/PrivateFrameworks/
    Apple80211.framework/Resources/airport: "Midgard" has weaker security 
    than Airport was configured for this network (2 vs. 255). Not joining for 
    security reasons.
    I'm guessing that has to do with me changing the network from WPA to WEP. But wouldn't deleting the preferences help with this? Are there some other prefs I could kill? Why would my Mac Pro accept the change fine and his MBP wouldn't?
  2. iFooBar macrumors newbie

    Mar 29, 2007
    Please report this problem to apple

    Apple will ignore your request unless you let them know what's up.

    Call their technical support line - 800 275 2273

    Tell them to report to network engineering that 2007-002 broke your wireless networking. If they even mention that you should get their airport device, make sure you reply here.

    They have to fix this.
  3. Vegeta-san macrumors 6502

    Aug 4, 2006
    Ok, first things first, iFoobar, I did what you asked about calling Apple and saying what you said because my MBP has had on and off problems with my routers WEP security and it has just been INFURIATING because the complicated steps I would talk on a piece of trash windows laptop would work yet all attempts on my MBP would not. Apple stated that my C2D MBP is outta the so-called 90 day support time so I simply told them to say what I needed to tecnical support and let them go.

    Now for you killmoms, I searched around on my Winblows box for an MBP wireless WPA fix on Apple's website. Thankfully, the second solution I clicked on worked. I sincerely hope this works for you as I understand first hand how frustrating this can be:
  4. BEET macrumors member

    Jul 7, 2004
    Guernsey, Channel Islands
    This is so annoying! I just phoned apple uk who said they weren't aware of this problem (before I found this thread) and that I probably just needed to update the firmware for my router (DLink DSL-G604T). This isn;t the case as the router is a few years old and doesn't have any recent firmware updates.
    I tried removing the WPA which did actually give me back a wireless connection until I tried to add a WEP that kindly removed it again for me. I have tried removing any security from the router and still don't get a connection. I have also tried the steps suggested by apple to no avail.
    I will call apple again on monday to discuss/ regester my complaint. Until then if anyone has any further suggestions they would be highly appreciated!

Share This Page