MacBook Pro randomly sleeps in clamshell mode

Discussion in 'MacBook Pro' started by Mr Dobey, Oct 26, 2009.

  1. Mr Dobey macrumors 6502

    Joined:
    Aug 8, 2008
    #1
    Under Snow Leopard 10.6.1 I have run into a problem with my MacBook Pro,

    When I close my laptop while connected to an external DVI display the system goes to sleep than wakes when I touch a key on my external keyboard and than falls a sleep again about 5 seconds later. Waking the computer again results in the same thing.

    Anyone else have this problem?
     
  2. atticus18244fsa macrumors 6502

    atticus18244fsa

    Joined:
    Jul 11, 2008
    Location:
    Waterloo, ON
    #2
    We'll I've spent hours trying to get clamshell to work in Leopard on my 15" 2.53GHz Summer 09 MBP. NEVER GOT IT TO WORK. No matter what I do. What adapter do you have? Because I have the monoprice adapter and I think that may be my problem.
     
  3. Mr Dobey thread starter macrumors 6502

    Joined:
    Aug 8, 2008
    #3
    Here you go

    I'm using a Xtreme mac DVI to HDMI cable to go to my TV for video and a stereo cable coming out of my headphone jack for audio.
     

    Attached Files:

  4. sn0warmy macrumors 6502a

    sn0warmy

    Joined:
    Mar 26, 2009
    Location:
    Denver, CO
    #4
    Woah, I'm having the exact same problem. It just started for me an hour ago.

    I posted a thread about it as well:
    http://forums.macrumors.com/showthread.php?t=809629


    I have no idea what is causing this. It was working fine before but now all of a sudden it will not stay awake or asleep with the lid closed and an external monitor plugged in.

    I have my monitor plugged in via DVI to Mini-Display adapter.
     
  5. Mr Dobey thread starter macrumors 6502

    Joined:
    Aug 8, 2008
    #5
    10.6.2

    Let's hope 10.6.2 will magically fix this. But for now I hope someone chimes in with some help.
     
  6. sn0warmy macrumors 6502a

    sn0warmy

    Joined:
    Mar 26, 2009
    Location:
    Denver, CO
    #6
    Hm, I just restarted my computer 2 times. And now it's working just fine all of a sudden.

    I don't get it.
     
  7. Mr Dobey thread starter macrumors 6502

    Joined:
    Aug 8, 2008
    #7
    sometimes

    Clamshell mode does work sometimes, but sometimes simply does not cut it.
     
  8. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
  9. sn0warmy macrumors 6502a

    sn0warmy

    Joined:
    Mar 26, 2009
    Location:
    Denver, CO
    #9
    "Make sure the computer is plugged in to an outlet using the AC power adapter."

    That was my problem. After plugging in my power cord, and restarting the computer it works just fine again.
     
  10. Mr Dobey thread starter macrumors 6502

    Joined:
    Aug 8, 2008
    #10
    well call me stupid!

    Thank You richthomas! you're right. and it was that simple. I must say I don't like this feature though because now I have to also move my power adapter every time I move my laptop to my living room to watch a movie on my TV. I wonder if there is a work around or command line to change this power requirement?
     
  11. rbtacevedo macrumors newbie

    Joined:
    May 18, 2010
    Location:
    Florida
    #11
    Still a problem!

    Has anyone gotten this to work yet? I am using a mini-displayport to HDMI adapter (Monoprice) and I cannot get it to work for the life of me. Even with a keyboard and mouse plugged in AND on AC power, the computer will NOT stay awake. I can restart the computer and shut the lid and have it show the grey Apple boot screen and everything on my TV, but then it sleeps. I wake it with the keyboard and it comes to the login screen but sleeps again 5 seconds later. Am I missing something? :confused:
     

Share This Page