MacBook Pro Retina doesn't recognize internal SSD

Discussion in 'MacBook Pro' started by ziher, Sep 23, 2015.

  1. ziher, Sep 23, 2015
    Last edited: Sep 23, 2015

    ziher macrumors newbie

    Joined:
    Jun 2, 2015
    #1
    Hi, I need Your help guys. After doing battery replace in my MacBook Pro 15'' Retina I probably damage my SSD disc or main board. Here's a problem. When I started Mac after repair, my os X ran normally. Then suddenly collapsed, I had to hard reset. That was the last time I was able to run os X from internal SSD. I ran Mac from external SSD and in disk utility verified Macintosh HD - it said there was some error (I don't remember what exactly it was).

    I was able to get access to Macintosh HD via Finder, copied all my files on external storage. After that I erased MacHD, but it never finished just freeze.. I had to reset mac again. From then there is no way to see my internal SSD (Macintosh HD) anymore. In disk utility there is only my external SSD. When I listed disks in terminal it also doesn't recognize internal SSD.

    I even tried to format it via Linux Ubutu but no luck…

    Please, anyone could help ??
     
  2. CoastalOR, Sep 23, 2015
    Last edited: Sep 23, 2015

    CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #2
    EDIT: Disregard, I missed Retina in the title of the thread which means PCIe flash storage.
     

Share This Page