Macbook Pro Retina early 2013 with screen artifacts

Discussion in 'MacBook Pro' started by Love4ndpeace, Apr 30, 2015.

  1. Love4ndpeace macrumors newbie

    Joined:
    Aug 5, 2013
    #1
    Guys, I need a little help here.

    These few days, I've been experiencing weird screen artifacts appearing on my macbook screen.

    I've took picture with my phone and you can check it on the attached files.

    I have been looking for the problem in the google and read about how macbook pro retina 15" early 2013 are experience screen problem and I wonder if i'm experiencing the same problem.

    Anyone can help me? will be much appreciated, thanks !
     

    Attached Files:

  2. brdeveloper macrumors 68020

    brdeveloper

    Joined:
    Apr 21, 2010
    Location:
    Brasil
    #2
    It can be the Discretegate. Read the following topic:
    http://www.macrumors.com/2015/02/19/2011-macbook-pro-repair-program-apple/
     
  3. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #3
    Those look like pressure marks on the screen to me. Do you use a keyboard cover?
     
  4. Love4ndpeace thread starter macrumors newbie

    Joined:
    Aug 5, 2013
    #4
    Yes, I have read about it. But I'm kind of living in secluded area without Apple Service Centre nearby. So I have to know for sure it is the same problem others are experiencing before I bring it to the Apple Service Centre. So far from what I have read, the problem occuring are distorted display and severe image retention and I still haven't seen anyone with similar problem like mine. Thanks for the help though.

    It has dropped few times, but the last drop was like 4 months ago and the problem only occured recently (like a week or two) so I don't think it is pressure marks. Plus this only occur when I switched it on and leave it overnight. And if I turn it off for several hours the screen will go back to normal and the problem reappears after few hours of working.

    Anyone else can help!? Or is there any problem related to my screen or is my graphic card failing? Does running too much heat is causing these?
     

Share This Page