Macbook Pro Retina extensions?

Discussion in 'MacBook Pro' started by brandonhisey, Feb 6, 2013.

  1. brandonhisey macrumors newbie

    Feb 6, 2013
    This is my first mac and I love it! Problem though all my file extensions are showing up. I have already been to finder preferences and unchecked "show all extensions" But all files still have the exceptions at the end.

    I can go to each individual file and select get info and "check" the hide file extensions and this fixes it for the specific file but I don't want to do this for every file.

    Any help?:confused:

  2. swerve147 macrumors 6502a

    Jan 12, 2013
    That's by design apparently. Both the preference in Finder has to be unchecked and the individual file have to manually be disabled for file extensions to be hidden (link)

    The solution involves writing a script in script editor as a kind of batch process to remove the extensions from multiple files in a folder (link). Unfortunately this link is old, so it may or may not work in ML (maybe an advanced user can chime in).

    Alternatively you can change the attributes of multiple files by selecting them, right-click, hold down Option (which changes the menu item from Get Info to Show Inspector), and select Show Inspector. That will allow you to batch process multiple files as well.

    I don't think there's a global solution to hide the extensions for every single file, although I could be wrong (I'm a new user too).

Share This Page