MacBook Pro Retina & Gamepads (specifically, Logitech Dual Action/F310)

Discussion in 'MacBook Pro' started by muotim, Jul 22, 2012.

  1. muotim macrumors newbie

    Joined:
    Jul 22, 2012
    #1
    First up - hi. Happy Retina MacBook Pro owner here, did my research, the screen looks awesome, the laptop is everything I expected but I have encountered a problem that doesn't seem to have been covered yet.

    I've exhaustively searched the web for info and can't find any other mention of this, so I'm hoping a thread here will at least attract some attention and possibly even a fix or workaround.

    I've recently bought a Logitech F310 gamepad for emulation purposes (as well as a few other games) on said Retina MacBook. MacRumors forums was partly responsible for me choosing the F310 as I've stumbled across a few threads that recommended the F310 for its plug and play compatibility with OS X via "D" input mode.

    The problem is that I cannot get the gamepad to be recognised by applications I know support it, for example sixtyforce and Snes9x among others. I've installed the trial version of USB OverDrive which (in a bizarre twist) does recognise the inputs, but it's a mapping tool and isn't any use for the analog sticks. I've held off buying GamePad Companion because I don't really want to buy a program I will have no use for when other programs that should already work do not.

    I've tested the gamepad with sixtyforce and Snes9x on my girlfriend's MacBook Air and it works 100% fine, no setup required. It is running 10.7.4 much like I am on the Retina. I have also tested the Aleph One engine (Marathon series) which apparently works fine with this gamepad to no avail - it doesn't detect anything.

    Does anyone have any idea why the RMBP won't recognise it with certain applications? Any reason USB OverDrive would recognise it but other applications would not? The only thing I can think of is that the Retina model has USB 3.0, though this should be fully backwards compatible or should flat-out refuse to work altogether (that goes for USB OverDrive too).

    If any RMBP owners can chip in their experiences with gamepads (PS3, Logitech, anything) then that might at least build a better picture for prospective buyers. As it is, all the forum threads and recommendations on sites like MacGamepads don't seem to apply Retina owners and it would be nice to provide some proper insight.

    Sorry for rambling!
     
  2. Speedy Gonzalez macrumors regular

    Joined:
    Jun 12, 2012
    Location:
    Alligator Bayou
    #2
    I guess people don't care about gaming on macbooks but I do

    I am playing portal and trine at the moment with a ps3 controller all you need is a Bluetooth dongle and free software emulator called motion joy I tried to make the software to work with the MacBook Bluetooth but I need that for my orochi mouse

    The experience is good ps3 controller just work like a 360 controller no problems at all I hope this help you
     
  3. sk3ro macrumors newbie

    Joined:
    Sep 10, 2012
    #3
    I'm interested in a fix too

    The controller worked fine on my iMac running Mountain Lion, but then I transfered my data to my Retina MacBook and now it doesn't work. Haven't tried any controller mapping software, I'd rather not have to...
     
  4. vahidfozi macrumors newbie

    Joined:
    Sep 15, 2012
    #4
    i am having similar issues using the low-end logitech dual action gamepad on a retina macbook pro 10,1
     
  5. vahidfozi macrumors newbie

    Joined:
    Sep 15, 2012
    #5
    FIXED!

    here's what i did to get my gamepad working with GTA: vice city

    so first of all a brief description of what happened. whenever i tried to play GTA with the logitech the dude would just run in a random direction no matter what was going on with the gamepad. basically the left-side direction joystick wasn't working and everything else was fine.

    so, i installed carvware's gamepad companion, which ends up as a system preferences pane. i think it cost me $8 to buy on the app store. now i have absolutely no affiliation with this company AND it seemed kinda shady, but anyway ...

    i opened the preference pane and plugged in the logitech dual action. now i am not entirely sure how this works, but i think the position sensor considers the upper left quadrant and lower right quadrant to be two separate axes.

    the "maximum" position for the upper left quadrant would be pointing straight up, while the "minimum position" would be straight left. this is pure speculation ... but ...

    so i selected the logitech dual action, pushed the left-hand joystick to the "northwest" position, which showed up as "x-axis" in the "selected element" window. i picked "multiple keys" and i hit "up arrow" for maximum and "left arrow" for minimum.

    then i pushed the joystick to "southeast", which showed up as "y-axis", put in down arrow for "maximum" and right arrow for "minimum".

    VOILA FIXED! i can now play GTA as before. :cool:

    but it cost me 8 bucks and i installed some software that i'm not 100% certain about. will post updates if anything changes.

    ----------

    i am going to bump this twice more so i can send a PM to the original poster
     

Share This Page