Macbook pro retina wakes up from sleep on its own

Discussion in 'MacBook Pro' started by Ipadlover29, Nov 27, 2015.

  1. Ipadlover29, Nov 27, 2015
    Last edited: Nov 27, 2015

    Ipadlover29 macrumors 6502a

    May 28, 2011
    My late 2013 15inch macbook pro retina with el capitan (10.11.1) seems to wake up from sleep on its own every few days. I have had this issue before even when I was running yosemite.

    Ive tried the following:

    Resetting SMC

    Resetting NVRAM

    disabled wake for wifi access

    disabled power nap

    disabled allow bluetooth devices to wake this computer

    disabled all notifications from showing in the lock screen

    File sharing is disabled

    Any recommendations?

    Thanks in advance,
  2. Rodan52 macrumors regular


    Sep 21, 2013
    Melbourne, Australia and Bali, Indonesia
    I guess you have already checked Log In Items to see if anything running in the background may be responsible, I was once caught out by Carbon Copy Cloner which had Wake for Backup set in it's preferences.
  3. Kissmyne macrumors 6502


    Apr 21, 2015
    Look in Console>Diagnostics and Usage Messages... if you know or can determine a time when this behavior occurs.. there will most likely be a log in Console about the event that led to waking...
  4. DeltaMac macrumors 604


    Jul 30, 2003
    Every few days? Is that on the same day (maybe at the same time) each week?
  5. simon lefisch macrumors 6502a

    simon lefisch

    Sep 29, 2014
    Are you using an external BT device? If so, go to BT options in Preferences and make sure "BT device can wake PC" is turned off.
  6. Ipadlover29 thread starter macrumors 6502a

    May 28, 2011
    I was finally able to catch it in the diagnostics and usage messages.

    This is what it said:

    2015-12-01 1:56:36.237 AM powerd[51]: smc_without_platform none

    SenderMachUUID: 27E902FC-A7A7-30EC-A8E8-1A6926D5ABDC
  7. DeltaMac macrumors 604


    Jul 30, 2003
    I don't see anything there that indicates any reason why you might have a wakeup.
    Your system.log would likely be a better place to look.

    With that said, from your list, you COULD try disabling darkwake mode, which is related to, but different from powernap.
    Some other info here:

Share This Page