Macbook pro running/booting extremely slow

Discussion in 'MacBook Pro' started by neliss, Mar 5, 2011.

  1. neliss macrumors newbie

    Joined:
    Feb 18, 2011
    #1
    My Macbook pro is running extremely slow lately.
    It takes me about half an hour to boot (i'm not exaggerating), and i get beachballs at nearly every click no matter what program i'm running. Strangely, from time to time the beachballing stops and i can work without troubles until it hits again.

    Things i tried:
    - Replacing the Harddrive with a fresh SSD. Same issues.
    - Harddrive disk repair / permission repair
    - Apple Hardware Test (also extended test) - No problems found
    - EFI firmware downgrade
    - Running verbose mode and fsck. Nothing strange except two notifications:
    "SATA WARNING: Enable auto-activate failed" and "AppleAHCIDiskQueueManager::setPowerState timed out after 100202 ms".
    - Checking the log files when a freeze occurs. No notifications.
    - PRAM reset

    It seems like my SATA interface pauses every now and then. When i run a DVD i hear it spinning down and back up periodically, and in activity logger i see strange peaks in the harddisk writes.

    System info:
    MacbookPro 5,5 (13 inch of mid '09)
    OSX 10.6.5
    EFI 1.7

    Does anyone know what could cause my problems?
    And more importantly, is there anything i could try to solve my problems?
    Thanks!
     
  2. fil3333, Mar 5, 2011
    Last edited: Mar 5, 2011

    fil3333 macrumors member

    Joined:
    Jan 21, 2009
    #3
    hi,
    i would try this:
    first take look in systemsettings - startvolume whether the macintosh hd is marked, if not mark it otherwise booting takes significantly longer.
    then restart the computer holding down the shift key. with snowleopard hold the finger on the shiftkay till you see a bar under the applelogo.... with leopard you have to hold the key till your mac is fully booted.
    next u open the program disc utility, now mark the 'macintosh hd' on the left side und press the button 'repair disc permissions'.
    for me it sounds like you have some trouble with the access rights...
    next would be a fresh install/what you kind of did with your ssd....
    do you have another ram lying around? try it out
    worst case.... logicboard!
    regards
     
  3. neliss thread starter macrumors newbie

    Joined:
    Feb 18, 2011
    #4
    The macintosh disk is marked as boot device, so this is not the problem.
    I tried booting in safe mode and repairing the permissions, but it didn't solve anything.
    I also tried removing part of the RAM and interchanging it (i have two modules), but it didn't change anything. I don't think both are broken.

    I'm still noticing large peaks in my disk activity when it freezes, i don't think this is normal.
     

Share This Page