MacBook Pro screen problems with new EFI?

Discussion in 'MacBook Pro' started by Archduk3, Mar 4, 2012.

  1. Archduk3, Mar 4, 2012
    Last edited: Mar 4, 2012

    Archduk3 macrumors member

    Joined:
    Feb 7, 2012
    #1
    So after googling and looking at several post and forums it seems to me. That a lot of people are having issues with their screens recently. Blacks going into either red or blue, flickering and acting up.

    I myself only have this issu now with external screen, and it of course only takes place when I get into my mac, at the log in screen there are no issues.

    Before the latest EFI was loaded in I never had this problem really, and I could work hours in any GPU demanding software and it would still work great.

    I tried changing the connection from DVI to HDMI, cables, and finally reset PRAM and SMC. I seems have the issue less and less with lower resolutions though, but still.

    My goal with this thread is just if we could narrow down the problem to latest EFI maybe we could help informing apple about it...

    I can confirm that this flickering only happens when my computer/graphics card gets warm. I shut it down to cool off and the flickering disappeared.
     
  2. paul117 macrumors regular

    Joined:
    Feb 17, 2012
    #2
    i have an early 2011 15" macbook pro 2.0ghz with 8gb gskill ram and a kingston hyperx ssd..... for a while i did have issues where on the rare occasion it would lock up with mouse and keyboard still working but that has since stopped happening..... i did also once have an issue where my webcam wasnt detecting but i reset the SMC and it worked fine from then on... (only major issue i have with my laptop now is it is a magnent for dirt screen if filthy and the keyboard is dirty :p)
     
  3. Archduk3 thread starter macrumors member

    Joined:
    Feb 7, 2012
    #3
    Maybe its just for 17"? :S
     

Share This Page