MacBook Pro Shuts Down at Grey Apple Screen

Discussion in 'MacBook Pro' started by eXpress, Dec 1, 2008.

  1. eXpress macrumors member

    Joined:
    May 20, 2007
    #1
    Hi everyone,
    Within the last day or so, my MacBook Pro started taking a very long time to start up. Today, it got to the point where once it started up (after about 20 minutes), I could barely perform any task on my computer. Even trying to open the Finder took about 10 minutes. I restarted my computer and this time when it shut down abruptly at the grey apple screen with the swirling timer. This now happens each time I try to turn on my computer. I can still boot the Windows Partition. I thought maybe my hard drive was corrupt, but I can access and open files from the Mac hard drive after extracting them with HFSExplorer on Windows. Any ideas on how to fix my problem? Just to note: I'm away at college and don't have my Leopard install disk so that is out of the question right now.

    Thanks for any help offered.
     
  2. macrem macrumors 65816

    macrem

    Joined:
    Mar 11, 2008
    #2
    Does it still happen after completely removing Windows?
     
  3. McBeats macrumors 6502a

    Joined:
    Apr 10, 2007
    Location:
    erf
    #3
    i had this happen to me 2 months ago, i ended up having to reinstall my original tiger disc and it worked from there on.

    so yeah, might have to get ahold of a leopard install disc somehow :(
    call your parents n ask them to mail it to ya or something :) and use ur windows partition in the meantime,

    good luck man
     
  4. brettshumaker macrumors newbie

    Joined:
    Dec 2, 2008
    #4
    mine started doing the same thing today...must be something going around haha I've been googling all day and finally came across this thread. I'm going to try booting from my leopard disc when I get home. Thanks in advance.
     
  5. Bob52ME macrumors newbie

    Joined:
    Jan 10, 2009
    #5
    MacBook Pro Shuts Down at Grey Apple Screen

    Yesterday my 2007 MacBook Pro 15" was working fine. This morning I tried to start the machine and it chimed nicely started the screen and the revolving gear then shut down. I have done a number of things:

    1. Started with battery only
    2. Started with battery removed
    3. Reset the PMU or equivalent in the MacBook Pro
    4. Reset the PRAM (I let it chime 5 times just for laughs)
    5. Removed indiviual RAM modules one at a time and reseated them
    6. Tried restarting with a Tiger Install disk - I have misplaced my Leopard disk otherwise I'd try that too
    I note that a previous responder indicated that his computer was taking longer and longer to start up. I think that I may also have noticed that as well, but I hadn't been concerned.

    I replaced the 120Gig HD with a 360 Gig HD over 6 months ago, but I don't believe this is the problem because I couldn't start up from the start up /install disk.

    Anyone have any additional thoughts? I will welcome all suggestions. This is my work computer and even though backed up with Time Machine, I am hitting the road on Monday for 4 days and would find this very inconvenient.

    Thanks.
     
  6. kainjow Moderator emeritus

    kainjow

    Joined:
    Jun 15, 2000
    #6
    Somehow I'm running into this problem right now. I was using the computer normally, then did a reboot and can't get past the Apple logo. It shows for about 10-15 seconds, then shuts down immediately. I can boot Windows on the same drive (on that now), and can boot 10.5 from another drive/CD just fine, so something has gone wrong with the file system from what I can tell. I ran Verify with no problems reported, but am going to run it again as I think I was using the 10.5 version and will try with 10.6.

    Update: I used 10.6 DVD to Verify Disk and Verify Permissions, no problems. I then booted holding down command-V (verbose mode) and made a video of the screen with my iPhone since the messages disappear too fast. The error I got was "Can't get kextd port".

    Update 2: Booted into single user mode (command-S) and ran fsck, no problems (as I suspected). Then I typed exit to continuing booting, and get the same kextd error.
     
  7. kainjow Moderator emeritus

    kainjow

    Joined:
    Jun 15, 2000
    #7
    Well I was able to boot into my backup from last night without any problems. I wrote a program to compare my System directories and didn't find anything except for some kext cache files that weren't the same. Maybe somehow that is/was the problem? Not sure, but I worked around the problem by installing OS X onto a new volume, creating a user account, then setting that user account to point to my existing user account on the volume that's not booting (I've been wanting to do this for a while anyways). For 99.99% of everyone with this problem I would say to just archive and install, or restore from a previous known working backup, or go to Apple and have them fix.

    UPDATE: so 3 months after I originally got this problem, I ran into it again. Twice. It was due to the file /etc/rc.cdrom. I had this file in place to test some software I was working on and if you're booting a Snow Leopard volume with that file, it will not work at all. So this is probably going to affect nobody else who comes across this post but thought I'd put it out there :)
     

Share This Page