Macbook Pro - slow Internet connectivity

Discussion in 'MacBook Pro' started by electron99, Nov 15, 2012.

  1. electron99 macrumors newbie

    Joined:
    Nov 15, 2012
    #1
    I have a 15inch Macbook Pro from 2009. OSX 10.6.8. A couple of months ago I got a new ISP and potentially have a connection in the high 30 Mbps range.

    But I have never been able to get benchmarks over 10Mbps on my Mac. Embarrassingly I got the ISP engineer over today, and on his PC he was achieving 32 Mbps.

    I'll mention what checks I have done:
    1. Used ethernet as well as Wifi, with all other internet connections turned off in the house. Similar results, although ethernet slightly faster.
    2. Got out my old PC laptop - and getting about 29Mbps on same wired connection I used for point 1 above.
    3. I have changed the Macbook's DNS settings to either google's or the ones recommended by Namebench - with little improvement.
    4. I have benchmarked my machine with Geekbench and it comes in at 3400, which is just above middle of the road for my spec.
    5. I have had a good look at Activity Monitor, and nothing is obviously hogging the CPU.
    5. I have spent 4 hours or so trawling the Internet for suggestions and I can't see anything that works?

    Any ideas and thanks for any input in advance!
    David
     
  2. Mr. Buzzcut macrumors 65816

    Mr. Buzzcut

    Joined:
    Jul 25, 2011
    Location:
    Ohio
    #2
    Hey! Post the output of netstat -i run in a terminal window. Do so before and after you run a speed test. We'll see if that shows anything.
     
  3. Acorn macrumors 68020

    Acorn

    Joined:
    Jan 2, 2009
    Location:
    macrumors
    #3
    a similar thing happened to me except I was also using an external monitor connected to the laptop. The external monitor was causing interference. I could see the speed drop just by connecting it and disconnecting it. The solution was to change the channel on my router.

    Although your situation is different, alot of people may be using the same channel in your area. so try a different channel. I get really bad results when the channel is set to automatic. 7 seems to give me the best results where i am.

    [​IMG]
     
  4. electron99 thread starter macrumors newbie

    Joined:
    Nov 15, 2012
    #4
    Here's the netstat output. Only using my wifi connection for this - and I managed 8Mbps:<<

    BEFORE speed check
    netstatDMP:~ electron$ netstat -i
    Name Mtu Network Address Ipkts Ierrs Opkts Oerrs Coll
    lo0 16384 <Link#1> 14277 0 14277 0 0
    lo0 16384 localhost ::1 14277 - 14277 - -
    lo0 16384 localhost fe80:1::1 14277 - 14277 - -
    lo0 16384 127 localhost 14277 - 14277 - -
    gif0* 1280 <Link#2> 0 0 0 0 0
    stf0* 1280 <Link#3> 0 0 0 0 0
    en0 1500 <Link#4> 00:26:4a:1b:2c:b2 484779 0 411645 0 0
    en1 1500 <Link#5> 00:26:bb:05:a6:f0 421907 0 365132 0 0
    en1 1500 192.168.1 192.168.1.64 421907 - 365132 - -
    en1 1500 dmp.local fe80:5::226:bbff: 421907 - 365132 - -
    fw0 4078 <Link#6> 00:26:4a:ff:fe:1b:2c:b2 0 0 0 0 0
    vnic0 1500 <Link#7> 00:1c:42:00:00:08 0 0 0 0 0
    vnic0 1500 10.211.55/24 10.211.55.2 0 - 0 - -
    vnic0 1500 dmp.local fe80:7::21c:42ff: 0 - 0 - -
    vnic0 1500 fec0:0:0:fe fec0:0:0:fea9::1 0 - 0 - -
    vnic1 1500 <Link#8> 00:1c:42:00:00:09 0 0 0 0 0
    vnic1 1500 10.37.129/24 10.37.129.2 0 - 0 - -
    vnic1 1500 dmp.local fe80:8::21c:42ff: 0 - 0 - -
    vnic1 1500 fec0:0:0:fe fec0:0:0:feaa::1 0 - 0 - -

    AFTER speed check
    DMP:~ electron$ netstat -i
    Name Mtu Network Address Ipkts Ierrs Opkts Oerrs Coll
    lo0 16384 <Link#1> 14298 0 14298 0 0
    lo0 16384 localhost ::1 14298 - 14298 - -
    lo0 16384 localhost fe80:1::1 14298 - 14298 - -
    lo0 16384 127 localhost 14298 - 14298 - -
    gif0* 1280 <Link#2> 0 0 0 0 0
    stf0* 1280 <Link#3> 0 0 0 0 0
    en0 1500 <Link#4> 00:26:4a:1b:2c:b2 484779 0 411645 0 0
    en1 1500 <Link#5> 00:26:bb:05:a6:f0 428523 0 369479 0 0
    en1 1500 192.168.1 192.168.1.64 428523 - 369479 - -
    en1 1500 dmp.local fe80:5::226:bbff: 428523 - 369479 - -
    fw0 4078 <Link#6> 00:26:4a:ff:fe:1b:2c:b2 0 0 0 0 0
    vnic0 1500 <Link#7> 00:1c:42:00:00:08 0 0 0 0 0
    vnic0 1500 10.211.55/24 10.211.55.2 0 - 0 - -
    vnic0 1500 dmp.local fe80:7::21c:42ff: 0 - 0 - -
    vnic0 1500 fec0:0:0:fe fec0:0:0:fea9::1 0 - 0 - -
    vnic1 1500 <Link#8> 00:1c:42:00:00:09 0 0 0 0 0
    vnic1 1500 10.37.129/24 10.37.129.2 0 - 0 - -
    vnic1 1500 dmp.local fe80:8::21c:42ff: 0 - 0 - -
    vnic1 1500 fec0:0:0:fe fec0:0:0:feaa::1 0 - 0 - -
     
  5. Mr. Buzzcut macrumors 65816

    Mr. Buzzcut

    Joined:
    Jul 25, 2011
    Location:
    Ohio
    #5
    Interesting. I was more interested in the wired connection but that's okay. How about netstat -r and ifconfig output? I want to see if those other interfaces are coming into play.
     
  6. electron99 thread starter macrumors newbie

    Joined:
    Nov 15, 2012
    #6
    Thanks so much for your interest! Now attached via Ethernet.....and here's the netstat -i, netstat -r and ifconfig results......


    DMP:~ electron$ netstat -i
    Name Mtu Network Address Ipkts Ierrs Opkts Oerrs Coll
    lo0 16384 <Link#1> 16732 0 16732 0 0
    lo0 16384 localhost ::1 16732 - 16732 - -
    lo0 16384 localhost fe80:1::1 16732 - 16732 - -
    lo0 16384 127 localhost 16732 - 16732 - -
    gif0* 1280 <Link#2> 0 0 0 0 0
    stf0* 1280 <Link#3> 0 0 0 0 0
    en0 1500 <Link#4> 00:26:4a:1b:2c:b2 494818 0 419044 0 0
    en0 1500 dmp.local fe80:4::226:4aff: 494818 - 419044 - -
    en0 1500 192.168.1 192.168.1.75 494818 - 419044 - -
    en1 1500 <Link#5> 00:26:bb:05:a6:f0 610409 0 543791 0 0
    fw0 4078 <Link#6> 00:26:4a:ff:fe:1b:2c:b2 0 0 0 0 0
    vnic0 1500 <Link#7> 00:1c:42:00:00:08 0 0 0 0 0
    vnic0 1500 10.211.55/24 10.211.55.2 0 - 0 - -
    vnic0 1500 dmp.local fe80:7::21c:42ff: 0 - 0 - -
    vnic0 1500 fec0:0:0:fe fec0:0:0:fea9::1 0 - 0 - -
    vnic1 1500 <Link#8> 00:1c:42:00:00:09 0 0 0 0 0
    vnic1 1500 10.37.129/24 10.37.129.2 0 - 0 - -
    vnic1 1500 dmp.local fe80:8::21c:42ff: 0 - 0 - -
    vnic1 1500 fec0:0:0:fe fec0:0:0:feaa::1 0 - 0 - -


    DMP:~ electron$ netstat -r
    Routing tables

    Internet:
    Destination Gateway Flags Refs Use Netif Expire
    default 192.168.1.254 UGSc 67 0 en0
    10.37.129/24 link#8 UC 4 0 vnic1
    10.37.129.2 0:1c:42:0:0:9 UHLWI 0 55 lo0
    10.37.129.255 ff:ff:ff:ff:ff:ff UHLWbI 1 19 vnic1
    10.211.55/24 link#7 UC 4 0 vnic0
    10.211.55.2 0:1c:42:0:0:8 UHLWI 0 434 lo0
    10.211.55.255 ff:ff:ff:ff:ff:ff UHLWbI 0 17 vnic0
    127 localhost UCS 0 0 lo0
    localhost localhost UH 0 110 lo0
    169.254 link#4 UCS 0 0 en0
    192.168.1 link#4 UCS 4 0 en0
    192.168.1.68 a4:ee:57:9:d1:c8 UHLWI 1 12 en0 1193
    192.168.1.75 localhost UHS 0 0 lo0
    192.168.1.254 20:f3:a3:7b:d3:e8 UHLWI 66 14 en0 1193
    192.168.1.255 ff:ff:ff:ff:ff:ff UHLWbI 3 58 en0

    Internet6:
    Destination Gateway Flags Netif Expire
    localhost localhost UH lo0
    fe80::%lo0 localhost Uc lo0
    localhost link#1 UHL lo0
    fe80::%en0 link#4 UC en0
    dmp.local 0:26:4a:1b:2c:b2 UHL lo0
    fe80::%en1 link#5 UC en1
    fe80::%vnic0 link#7 UC vnic0
    dmp.local 0:1c:42:0:0:8 UHL lo0
    fe80::%vnic1 link#8 UC vnic1
    dmp.local 0:1c:42:0:0:9 UHL lo0
    fec0:0:0:fea9::1 0:1c:42:0:0:8 UHL lo0
    fec0:0:0:feaa::1 0:1c:42:0:0:9 UHL lo0
    ff01:: localhost Um lo0
    ff02:: localhost UmC lo0
    ff02:: link#4 UmC en0
    ff02:: link#7 UmC vnic0
    ff02:: link#8 UmC vnic1


    DMP:~ electron$ ifconfig
    lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
    inet 127.0.0.1 netmask 0xff000000
    gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
    stf0: flags=0<> mtu 1280
    en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 00:26:4a:1b:2c:b2
    inet6 fe80::226:4aff:fe1b:2cb2%en0 prefixlen 64 scopeid 0x4
    inet 192.168.1.75 netmask 0xffffff00 broadcast 192.168.1.255
    media: autoselect (100baseTX <full-duplex,flow-control>)
    status: active
    en1: flags=8823<UP,BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500
    ether 00:26:bb:05:a6:f0
    media: autoselect (<unknown type>)
    status: inactive
    fw0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 4078
    lladdr 00:26:4a:ff:fe:1b:2c:b2
    media: autoselect <full-duplex>
    status: inactive
    vnic0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 00:1c:42:00:00:08
    inet 10.211.55.2 netmask 0xffffff00 broadcast 10.211.55.255
    inet6 fe80::21c:42ff:fe00:8%vnic0 prefixlen 64 scopeid 0x7
    inet6 fec0:0:0:fea9::1 prefixlen 64
    media: autoselect
    status: active
    vnic1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 00:1c:42:00:00:09
    inet 10.37.129.2 netmask 0xffffff00 broadcast 10.37.129.255
    inet6 fe80::21c:42ff:fe00:9%vnic1 prefixlen 64 scopeid 0x8
    inet6 fec0:0:0:feaa::1 prefixlen 64
    media: autoselect
    status: active
     
  7. Mr. Buzzcut macrumors 65816

    Mr. Buzzcut

    Joined:
    Jul 25, 2011
    Location:
    Ohio
    #7
    Drat. I had a hunch that your Mac might not be negotiating the correct link speed or duplex but I don't see any indication of that.

    Did the ISP tech connect to the same cable that you use for your Mac? I'm reaching here but maybe a switch port is flaky.

    I'm not sure what else you can check. I hope someone else will have more troubleshooting suggestions.

    Good luck!
     
  8. electron99 thread starter macrumors newbie

    Joined:
    Nov 15, 2012
    #8
    Many thanks Buzzcut. Yes, using same cable at ISP tech and have wiggled around on the PC here and that still gets consistently good results.
    I have a horrible feeling that this will get resolved by a reinstallation of my OS, but if any other ideas I'm very happy to try them out! Only other thought is if I have any network settings that are off - I've attached what they are at present....
     

    Attached Files:

Share This Page