MacBook Pro start up/black screen

Discussion in 'MacBook Pro' started by AGOBT, Feb 7, 2011.

  1. AGOBT macrumors newbie

    Joined:
    Feb 7, 2011
    #1
    I was installing OSX 10.5 (from 10.4.??) when my computer froze up after 4% completion. I attempted the install several more times with the same result so I tried to reboot using the 10.4.?? as my start up disk. The computer chimes, I get a gray screen for a couple of second and then I get the following:

    localhost:/ root# CSRHIDTransitionDriver::stop
    IOBluetoothHCIController::start Idle Timer Stopped

    If I hit "return" I then get:

    localhost:/ root#

    I've sapped the pram (hoping it would be that easy) but still the same thing.

    What I believe has happened is that my harddrive got renamed during the 4% install and now that I'm trying to boot up using it, the computer can't find it (just my guess). I ran the fsk (or whatever the line code is to check my harddrive) and everything came back "OK". So I'm at a loss. Can any one please help? Thanks!
     
  2. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #3
    Here are a few things that could cause an install to fail:

    1) Bad RAM
    2) Bad Hard Drive
    3) Bad Install Disk
    4) Corrupt directory structure on hard drive

    There are other possible explanations, but bad SATA ports or cables are very rare, as are power supplies that cause hard drives to vanish. So, run Disk Utility or Disk Warrior to make sure no major errors show up with the directory structure. If you let the disk go all the way through its verification stage and didn't skip it, then the disk is likely fine.
     

Share This Page