Macbook Pro stuck on gray screen with apple logo

Discussion in 'MacBook Pro' started by hushamahmed, Mar 1, 2014.

  1. hushamahmed macrumors newbie

    Joined:
    Mar 1, 2014
    #1
    I just replaced my 500 GB hard disk a day ago and have so far installed a bare minimum applications but my macbook pro (8GB 2012) is stuck at the gray screen with apple logo at the reboot.

    I have already tried running safe mode but it won't turn on. I tried fsk -fy method too but to no effect. I can still enter into recovery mode and can verify my harddisk and it shows no repair needed. But even when I try to install OS Mountain Lion X again, it says, "There was an error in initiating the install. Please run the application again".

    Your help will be appreciated.
     
  2. hushamahmed thread starter macrumors newbie

    Joined:
    Mar 1, 2014
    #2
    Also while Performing verifying permissions on the disk in recovery I read this in status:
    group differs on "Library/Preferences/com.apple.Alf.plist";should be 80;group is 0

    And few other permission differ notifications
     
  3. nickandre21 macrumors 6502a

    Joined:
    Jun 21, 2012
    #3
    Well you can try formating your partition again and reinstalling it with the install on an external bootable hard drive. Time machine backups can help you with this. If all else fails its the hard drive. Try resetting the smc and pram to see if it helps.
     

Share This Page