Macbook pro suddenly slowed down over night!

Discussion in 'MacBook Pro' started by Nathmk6, Sep 25, 2015.

  1. Nathmk6 macrumors newbie

    Joined:
    Sep 25, 2015
    #1
    Hi people,

    I was hoping someone could help me out with an issue. My Macbook Pro, mid 2012 i5 suddenly slowed down dramatically overnight almost to the point where its unusable.

    Ive never had an issue with my MBP until now. A few months back I installed a Samsung 850 evo, 500 gb and have never experienced any issues. Trim Enabler has always always been running in the background. Initially I thought it was a similar problem to the Samsung 840 evo's to which Samsung provided a patch. However I connected the MBP to another Mac and booted the SSD a 'portable' hard drive and it was reading and writing at normal speeds. In addition to this, clicking on the address bar in safari would take several moments which lead me to believe its not an hard drive issue.

    I ran activity log and saw nothing that would be draining all of its processing power. In the last two weeks I have not installed anything new. My next step is to see if Yosemite is causing any random issues but im hoping to avoid this as this will require a fresh re install. And im hoping its not a hardware problem.

    Has anyone experienced any anything similar or does anyone know how to resolve this issue.

    Thanks - Nathmk6
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Check the crash logs, disk utility (for errors) and run the Apple Hardware Test to see if anything kicks out.
     
  3. jermy4 macrumors demi-god

    Joined:
    Jun 27, 2010
    #3
    Run disk utility and repair disk permissions and verify disk, it sounds like it could be some sort of corruption or file permission issue especially since you said it ran at normal speeds when connected to a different computer.
     
  4. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #4
    Have you tried shutting it down (power all the way off), and then restarting?
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    I'm confused here... you took the 850 out and booted to it in an external enclosure?

    What you are describing does sounds like a bard drive or possibly a bad drive cable. The real test would be to pop the SSD in an external USB enclosure then option key boot to that. If that works fine, that tells you it is likely the internal drive cable.
     
  6. Nathmk6 thread starter macrumors newbie

    Joined:
    Sep 25, 2015
    #6
    Thanks for the help. Currently running the extended test on the hardware after the preliminary test showed no faults. I ran disk utility and all was well so this is definitely strange. Its looking like a fresh install might be the best option.
     
  7. jermy4 macrumors demi-god

    Joined:
    Jun 27, 2010
    #7
    Maybe try creating a new user and see if it performs better, could be something in your user profile on your mac.
     

Share This Page