macbook pro to sony lcd via dvi audio problem

Discussion in 'MacBook Pro' started by Davidsilence, Oct 22, 2007.

  1. Davidsilence macrumors member

    Joined:
    Oct 3, 2005
    Location:
    Brighton UK
    #1
    Hi

    I'm connecting my mbp to my new lcd sony bravia via dvi to hdmi lead and then connecting the sound via headphone jack to tv's 2 x phono, however i'm getting lots of audio noise bleeding through tv speakers underneath the main audio feed, i'm certain that its not a dodgy lead as iv'e tried 3 of them, however if i unplug the dvi lead the noise goes away, is it possible that the hdmi input is conflicting with the phono connection somehow, any suggestions appreciated
     
  2. waywardsage macrumors 6502

    waywardsage

    Joined:
    Dec 22, 2006
    Location:
    CA
    #2
    could be a ground loop problem. You might want to try the digital audio out. Better sound, and it would definately solve the problem.
     
  3. mcgarry macrumors 6502a

    mcgarry

    Joined:
    Oct 19, 2004
    #3
    I'm having a similar problem with my Philips LCD TV. Same connections as Davidsilence. I'd describe the noise as a windy-fuzz, if that makes any sense, it's not just static. It fluctuates in pitch, but not directly tied to any computer activity as far as I can tell (nothing obviously audible like HD activity, for example), except that if I turn off a connected computer, it gets a bit quieter.

    The weirdest part for me is that once it starts-- anytime I use the computer hooked up to the TV-- I can totally disconnect the computer, turn it off, unplug it even, and the sounds remains on that TV input, until I turn the TV off/on.

    The TV can make these sounds even if the separate audio cable is never connected-- just the HDMI-DVI connection does it.

    I've tried two computers, no difference. Two DVI cables, no difference. Two audio cables, no difference. Something happens to the TV when it is asked to get the HDMI signal from the computer, and it can't recover.

    Philips phone support was stumped, posts on a TV-centric board have gone unanswered.

    Davidsilence, or anyone else, does any of this match your TV's behavior? Thanks
     
  4. JHNguyen macrumors member

    Joined:
    Apr 14, 2006
    #4
    Sorry to bring this back up.. but, I came across this problem today..
    I remembered I have an old griffin imic.. (I believe they still sell them) I connected it via USB, plugged my speakers in and no more noise. :)

    Hope that helps some of you.
     
  5. johnwook macrumors newbie

    Joined:
    Mar 24, 2009
    #5
    mcbook & sony problems

    hi David, i know you posted ages ago. but i am trying to connect my macbook to a sony bravia and having problems. I use a mini-dvi to hdmi adapter and then hdmi into the tv which transmits the picture fine. However, when i try and transmit the sound over using a mini-jack phono from the headphones it won't pick up any sound. On the Tv i can select different external sources. If i select the hdmi it shows the screen, and if i select the PC it makes the sound work, but i can't select them both at the same time! The sony doesn't give me that option (i'm pretty sure). Do i have to use a 15pin to transmit the picture instead of hdmi? it seems a bit daft! I can't figure it out!! How did you get yours to work? I also, experience that hum when i turn he TV sound up when its connected to the macbook and is transmitting sound.
    ta muchly!
     
  6. pokeydom macrumors newbie

    Joined:
    Jan 9, 2011
    #6
    macbook to sony lcd via mini dvi to hdmi + 3.5 audio jack to phone.****no audio***

    I have exactly the same problem as David below, any ideas greatly appreciated. Cheers. Dom

    hi David, i know you posted ages ago. but i am trying to connect my macbook to a sony bravia and having problems. I use a mini-dvi to hdmi adapter and then hdmi into the tv which transmits the picture fine. However, when i try and transmit the sound over using a mini-jack phono from the headphones it won't pick up any sound. On the Tv i can select different external sources. If i select the hdmi it shows the screen, and if i select the PC it makes the sound work, but i can't select them both at the same time! The sony doesn't give me that option (i'm pretty sure). Do i have to use a 15pin to transmit the picture instead of hdmi? it seems a bit daft! I can't figure it out!! How did you get yours to work? I also, experience that hum when i turn he TV sound up when its connected to the macbook and is transmitting sound.
    ta muchly!
     

Share This Page