Macbook Pro Unibody Headphone Jack Not Working.

Discussion in 'MacBook Pro' started by juddernaut, Mar 15, 2010.

  1. juddernaut macrumors newbie

    Joined:
    Dec 23, 2008
    #1
    I have a Macbook Pro 13" unibody I purchased in June 2009. Just recently, the headphone jack stopped working. I tested many different headphones and speakers, and none of them work. I am suspecting a hardware issue, because when I plug it in, i head the static while it is being plugged in. However it does not switch the audio. The only thing is, if it was a hardware problem, wouldn't it be stuck in the headphone mode because the switcher is stuck? Thanks!
     
  2. juddernaut thread starter macrumors newbie

    Joined:
    Dec 23, 2008
    #2
    Never mind, I held down the left shift, control, and option keys + power button for 4 seconds, waited 10, then powered on. Now it works!
     
  3. chaywoo macrumors newbie

    Joined:
    Oct 6, 2009
    #3
    Didn't work for me

    My headphones still dont work after holding the ctrl + shift and power button trick..
    Any other ideas? It used to work, then all of a sudden, I went to use it tonight, and the internal speakers stay on, but the headphones never kick in..
    Hmmm, I did bump the macbook pro pretty good the other day when I was designing some duct work in a room. It wasnt dropped, just bumped the side of it agains a stainless steel shelf.. But I have a black plastic protective cover on it..

    Oh great.. Well, I guess I will try the latest updates, and if that doesn't work, kiss the headphone jack good bye..

    I still have an old dell laptop that I dropped on the cement a few times, kids ripped off a couple of the keyboard buttons, the back side of the monitor plastic is coming off, its been beat pretty bad, but everything still works on it... Maybe I will have to transfer my most recent audio mix down of a song Im working on to the dell so I can listen to it in the headphones.. hahahaha



    no way, i dont believe it..

    On my way to software upgrades..
     
  4. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #4
    Two things:

    1. If you look in the headphone port is a red light shining?
    2. Under System Preferences/Sound/Output is Digital Out | Built-In Output shown as selected?

    If the answers are yes, what you are experiencing is that the micro switch for the optical audio out is accidentally getting turned on and sticking in the on position.

    To get the light to go off you can also try inserting and removing a headphone/speaker plug. Even something like a toothpick or a bamboo skewer inserted and moved around will sometimes work. Whatever you use be careful to not break it off in the headphone jack. Good Luck.
     
  5. FloatingBones macrumors 65816

    FloatingBones

    Joined:
    Jul 19, 2006
    #5
    I had this problem on my unibody Macbook. I'm using the Sennheiser MM60 iP headset, which works fine on the Mac and my iPod Touch, but has a slightly different shape than the Apple headphones.

    My computer has gotten stuck in digital output mode three times. The computer thinks there's a digital output source connected through the headphone jack and the red light is shining through that port. I went through all of the reset/reboot genuflections suggested; they made no difference.

    The thing that fixed it was to plug in and remove a standard Apple headphone to the port. After that, things are happy. I have now gone weeks using my MM60 iP headset and the speaker works correctly whenever I disconnect that headset.

    I was very happy that the Genius Bar staffer did this one test. Otherwise, I was in for a world of hurt with a $$$ logic card replacement.

    Hope that helps.
     
  6. zipur macrumors 6502

    Joined:
    Mar 3, 2011
    Location:
    The great state of Texas
    #6
    Headset jack not working. until...

    I held down the left shift, control, and option keys + power button for 4 seconds, waited 10, then powered on as stated above and it worked for me also. Happy Days, I don't have to got to the Apple Store which is alway crowded with no parking. Oh and make sure you're playing
    String Quartet No. 2 in D Major: III. Notturno I don't know if it helped but thats what stated playing.

    Hope this helps someone else.
     
  7. Interstella5555 macrumors 603

    Interstella5555

    Joined:
    Jun 30, 2008
    #7
    Resurrecting a three year old thread to confirm and already confirmed fix works? Nice. Try making an appointment at the store if you need to go in as is standard practice.
     

Share This Page