Macbook Pro Wifi issues

Discussion in 'MacBook Pro' started by PEN10k, Mar 17, 2015.

  1. PEN10k macrumors regular

    Joined:
    Jul 3, 2012
    Location:
    Denmark
    #1
    Hello guys
    Im having some issues with the wifi connection on my 2014 rMBP, running Yosemite 10.10.2.

    Sometimes the wifi connect almost gets non existing, even though I'm still connected to the router. I can easily browse on the same network on my iPhone, from the exact same position, but the wifi on my Macbook is just ridiculously slow.. Someone know any tips to fix this?? Super frustrating..

    Thanks in advance
     
  2. adamhenry macrumors 65816

    adamhenry

    Joined:
    Jan 1, 2015
    Location:
    On the Beach
    #2
    Which protocol are you using and which frequency?
     
  3. PEN10k thread starter macrumors regular

    Joined:
    Jul 3, 2012
    Location:
    Denmark
    #3
    What do you mean by protocol??
     
  4. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #4
    Likely to be Bluetooth interference, try turning off BT and see if the connection improves.
     
  5. adamhenry macrumors 65816

    adamhenry

    Joined:
    Jan 1, 2015
    Location:
    On the Beach
    #5
    802.11g, 802.11n, or 802.11a?

    ----------

    Thats what I was thinking when I asked about the frequency above. Switching to 5GHz freqs. could also alleviate BT interference.
     
  6. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #6
    Yes, the trouble is 5GHz is such short range (even compared to 2.4GHz), that that can fool the user into thinking it makes no difference.

    Hopefully we can move forward when OP lets us know...
     
  7. PEN10k, Mar 18, 2015
    Last edited: Mar 18, 2015

    PEN10k thread starter macrumors regular

    Joined:
    Jul 3, 2012
    Location:
    Denmark
    #7
    802.11n :)

    Might explain why it works great in school, where I don't have any bluetooth devices connected, but it only bugs while I'm at home, with mouse and keyboard connected..
     
  8. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #8
    Quite possible, easily tested by turning BT off at home for a while and seeing if the issue stops. If it does then turn BT back on and try getting the WiFi source closer at home and possibly changing WiFi channels.
     
  9. PEN10k thread starter macrumors regular

    Joined:
    Jul 3, 2012
    Location:
    Denmark
    #9
    Thanks for the answer, I'll give it a shot!
    How do I change the WiFi channel?? :)
     
  10. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #10
    Login to your modem/WiFi router and it will likely be in the wireless settings there. It is probably set to "auto" but try several channels (there are apps that will tell you what channels are in use around you).
     
  11. PEN10k thread starter macrumors regular

    Joined:
    Jul 3, 2012
    Location:
    Denmark
    #11
    I turned off bluetooth, and yes, the wifi works without any problems now.
    Where do I log in to the router?
     
  12. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #12
    Depends on the router make/model - best to google for instructions if you don't have them.
     

Share This Page