Macbook Pro wifi speed vs Iphone6/IpadAir2 wifi speed

Discussion in 'MacBook Pro' started by [YSL], Jul 24, 2015.

  1. [YSL] macrumors newbie

    Joined:
    Jul 24, 2015
    #1
    Hello,

    I got this issue, that is really annoying. Two weeks ago i bought a TimeCapsule (2GB). I've set it up and everything works like a charm.... EXCEPT the download speed on my 2 macbook pros. Using the same settings on speedtest.net (prefered server, etc) on all devices, i get the following results:

    Iphone 6 (2 of them) and Ipad Air 2:
    Ping: 6
    Download: 24000 kB/s
    Upload: 22000 kB/s

    Macbook Pro 13" early 2011 and Macbook Pro 13" early 2015:
    Ping: 6
    Download: 16000 kB/s
    Upload: 15000 kB/s

    Every test that i have ran i made sure that that device is alone in the network. After a couple of tests i joined all the devices to the network, but there was no change in results.

    My WiFi is set up as a 5Ghz one. Right now, the channels for the 2.4GHz and 5GHz are automatic. The distance to the time capsule is about 2 meters and it is in line of sight.
    On both my laptops i checked (using alt+click on wifi) the signal and noise and they were both in order.
    The early 2011 MBP was connected at 450 Mbps
    The early 2015 MBP was connected at 975 Mbps

    I've tried all the channels for the 5GHz network, same results
    I tried to rule out speedtest.net (because of flash and OSX), but even on torrents i am still not able to get more than 16 MB/s

    Then, i connected the ethernet cable to the 2011 MBP and i was able to get 23MB/s... so the actual connection is ruled out.

    Same speeds (and the same differences) i get when the TimeCapsule is set up as Automatic (no separate 5GHz network).

    However, what i noticed was that i can actually write on the Time Capsule's HDD with 35+ MB/s.

    Maybe you guys know something i don't or that i didn't think of. I can't understand why on iphones and ipad i can get 20+ MB/s and on MBPs (even on the 2015 one) i can't get past 15MB/s over WiFi.

    Thanks in advance,
    /R
     
  2. Cuniac macrumors 6502a

    Joined:
    Jan 23, 2013
    Location:
    Phoenix
    #2
    Well first off The 2011 does not have AC so it will never connect faster than 450Mbp (The max for wireless N). As for the 2015 that connection speed of 975 is great. The AC Time Capsule can do up to 1300, but I have never seen a device actually connect that high before.

    With your computer saying it is connecting at those speeds, that is way more than enough to be able to pull your net plan speeds. I could be something software related on the 2015. Maybe your firewall is on, maybe you have 3rd party security software installed, maybe there is something causing EMI next to that laptop. I would check the firewall, and disable any 3rd party security software you may have, then turn off all other devices (not sleep but off) and take it to about 3 feet away form that router and retest.
     
  3. Kissmyne macrumors 6502

    Kissmyne

    Joined:
    Apr 21, 2015
    #3
    What he said but my suspicion would be Time Machine specifically, if you have it configured. I would turn Time Machine off and retest to rule it out.
     
  4. [YSL] thread starter macrumors newbie

    Joined:
    Jul 24, 2015
    #4
    Thanks for your replies.
    Indeed, i had time machine enabled, so i disabled it and ran some tests again. Still same results. (16MB/s UP, 15 MB/s Down, Ping 29 (lower this time)).
    No firewall active, no 3rd party firewalls or antivirus.

    I even tried with the laptops plugged in. Same results.

    What puzzles me is that i can transfer over WiFi, between the 2 laptops, with 30-35 MB/s (or at least that's what iStat Menus is showing for WiFi). Same speed i get when writing or reading on the TC's internal storage. So the WiFi connection can indeed handle these speeds.

    I've attached my current connection on laptop.

    /R
     

    Attached Files:

Share This Page