MacBook Pro will not boot

Discussion in 'MacBook Pro' started by Monger!, Oct 24, 2014.

  1. Monger! macrumors newbie

    Joined:
    Oct 24, 2014
    #1
    I am helping a friend with his MacBook Pro which will not boot.
    First I should note that I am not proficient with Apple computers.

    The computer turn on to and show the Apple logo and spinning wheel, nothing further.
    I have tried to boot in safe mode (shift pressed at startup). The additionally displays a progress bar that disappears at approximately the 30-40% mark but continue to display the Apple logo and spinning wheel.
    I have performed a Reset NVRAM (Option-Command-P-R). Nothing displayed, but reboot in 5-10 seconds.
    Turning it on while holding the Option key displays a HD icon labeled SnowLeopard and a button with an arrow. Clicking the arrow again displays the Apple logo and spinning wheel.
    I can boot in single user mode (Command-S) and get to a command line.
    LS shows me files and folders OK.
    FSCK -F runs for about 90 seconds checking and terminate with the message: The volume "SnowLeopard appears to be OK".
    Pressing D or Command-R does nothing
    Using verbose startup halts for sometime at "AppleYukon2: RxRingSize <= .....", but continues.
    Then shows 2 lines:
    "BootCacheControl: could not create temporary playlist file: No such file or directory"
    "BootCacheControl: could not write playlist"
    Lastly I tried chmod -R -N /Volumes, but get message "chmod: Failed to clear ACL on file /Volumes: Read-only file system"

    The original CD with operating system is not available.
     
  2. zeemeerman2 macrumors 6502

    Joined:
    Feb 21, 2010
  3. Lachhh macrumors regular

    Joined:
    Aug 30, 2014
    Location:
    Mainland Europe
    #3
    Try this, if you haven't already.
    http://forums.appleinsider.com/t/119889/macbook-pro-wont-boot-start
    And this.
    http://support.apple.com/kb/TA20809?viewlocale=en_US&locale=en_US
     
  4. Monger! thread starter macrumors newbie

    Joined:
    Oct 24, 2014
    #4
    That would have to be hardware that is not used in single user mode as all appears OK there.
    Not sure what that could be.
     
  5. Lachhh macrumors regular

    Joined:
    Aug 30, 2014
    Location:
    Mainland Europe
    #5
    Nope, highly unlikely.
     
  6. Monger! thread starter macrumors newbie

    Joined:
    Oct 24, 2014
    #6
    Appreciate the help, however, as far as I could continue I followed the steps
    Still no change in the boot.
    A month ago I was fiddling around with this issue a but and found a tip to press a set of key during startup that gave me another line where the booting stopped. The was not the Verbose feature.


    Link 1.
    1. Reset PRAM - Done
    2. Reset SMC - Done
    3. Grab a copy of disk warrior http://www.alsoft.com/diskwarrior/index.html and try and boot from that - Not done.
    Is it possible to make a bootable disk or USB on a Windows computer?

    Link 2.
    1. Start up in single-user mode.
    2. Type: mount -uw /
    3. Press Return.
    4. Type: ln -s /private/etc etc
    If this alert appears: "File already exists," execute the following command, then repeat the last step:
    mv /etc /private/tmp/etc.delete
    5. Press Return.
    6. Type: mv /var /var.delete
    There is a space between "/var" and "/var.delete".
    7. Press Return.
    Tip: If you see the message "No such file or directory," make sure that the spacing and spelling are correct, then repeat the last two steps. If you still see this message after the second attempt, continue to the next step.
    8. Type: ln -s /private/var var
    9. Press Return.
    10. Type: ls -l | grep ">"
    11. Press Return.

    Look for these two items in the output:

    lrwxrwxr-t  1 root  admin  {date} etc -> private/etc
    lrwxrwxr-t  1 root  admin  {date} var -> private/var

    If any of these are not present, repeat the necessary steps above until they are.

    12. Type: reboot
    13. Press Return.

    Completed all 13 steps, but had to manually create the folders /Private/Etc
     
  7. Monger! thread starter macrumors newbie

    Joined:
    Oct 24, 2014
    #7
    Perhaps I have reached a dead end (with the tools and knowledge that I have) and need to consider alternatives.

    I have managed to backup all user files, although I would like to recover and repair.
    Here are some thoughts.

    The current operating system is OS X 10.6.8 (SnowLeopard) and I have seen that version for sale eBay for about $20.
    My question is with that give me a tool to repair the installed operating system and maintain the installed applications?
    Ultimately the owner wants to install Yosemite, but I suspect it would be a stretch to think that it will install on top of (upgrade) a corrupt older version.

    If the current version cannot be repaired is it possible to pickup a Yosemite CD/DVD from an Apple Store and start from scratch.

    Any help and suggestions are much appreciated.
     
  8. Monger! thread starter macrumors newbie

    Joined:
    Oct 24, 2014
    #8
    Fixed the problem.
    Downloaded a DVD image of Snow Leopard and used TransMac to create a USB install media.
    Reinstalled the operating systems with all user files and applications remaining intact.
    Only some preferences disappeared.

    With a new install being near non-destructive, I would think that a prudent recommendation if simple steps does not fix the problem is to just reinstall.

    Not bad for someone who have never touched a Mac before

    Thank you Lachhh for the time you took to help
     
  9. Monger! thread starter macrumors newbie

    Joined:
    Oct 24, 2014
    #9
    One more note.

    When I was backing up the data I asked the owner which files to backup.
    He noticed the "/Private" folder and noted that it was one the previous owner made, but I noted that I made that folder (explained in Post 4).

    Later I asked him when exactly the crash happened.
    He told me that he was deleting unnecessary files, but did not touch anything that he did not know.

    When I saw the reinstalled folder structure I noticed that /Private indeed contained a lot of important files and folders configuring the boot and other preferences.

    With his statement that the /Private folder was made by the previous owner and his cleanup of only stuff he knew I concluded: HE DELETED THE FOLDER. ... end of usable computer.
     

Share This Page