MacBook Pro won't boot after RAM upgrade

Discussion in 'MacBook Pro' started by Stuipdboy1000, May 9, 2012.

  1. Stuipdboy1000 macrumors 6502a

    Stuipdboy1000

    Joined:
    Jun 30, 2007
    Location:
    Perth, Scotland, UK
    #1
    Hi all. I upgraded the RAM in my MacBook Pro (13 inch, early-2011) this morning. I was wanting to go from the stock 4GB to 8GB. I purchased the RAM online from Crucial, one of the most reputable brands around. However, after I had popped the new RAM in and tried to boot it, nothing. There is no life in this thing. The battery indicator on the side won't even light up.

    I wouldn't consider myself an expert in computer upgrades but I have done this before on other MacBooks so I knew what I was doing. I don't know if I've maybe nudged a cable by accident?

    I have tried everything listed on Apple's website to try and receive it with no luck. Have you guys got any suggestions before I go and book a Genius Bar appointment?
     
  2. Stuipdboy1000 thread starter macrumors 6502a

    Stuipdboy1000

    Joined:
    Jun 30, 2007
    Location:
    Perth, Scotland, UK
    #3
    Yeah. I followed the instructions on Apple's website just to be sure. I tried putting the old RAM back in it to see if I had maybe been sent faulty RAM but that doesn't seem to have worked either.
     
  3. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #4
    you may of damaged the RAM slots
     
  4. 9Benua macrumors member

    Joined:
    Aug 20, 2011
  5. Stuipdboy1000 thread starter macrumors 6502a

    Stuipdboy1000

    Joined:
    Jun 30, 2007
    Location:
    Perth, Scotland, UK
    #6
    Checked the battery connection but it seems pretty snug.

    I've booked an appointment at the Genius Bar tomorrow morning and I'll see what they have to say. I'll keep you posted.
     

Share This Page