Macbook pro wont boot. Need help.

Discussion in 'Mac Basics and Help' started by kassvein, Jul 28, 2015.

  1. kassvein macrumors newbie

    Joined:
    Jul 27, 2015
    #1
    Hey,
    My friends old macbook 2010 pro wont boot ( 13inch version )

    http://www.everymac.com/systems/app...o-2.4-aluminum-13-mid-2010-unibody-specs.html

    He didnt use it in some time so i dont know is there any water damage example, opened back side and looked for corrosion and didnt see any atleast on back side of motherboard. Re-connected every cable on back side of motherboard, Nothing looks to be broken. I removed battery cable and tried to boot and nothing happens, no fans or any sounds. Power cord has green light stable when plugged to macbook, thats only light im seeing.

    I got some life into it when i press power button for 10seconds then connect power cord to macbook ( it has no light at all when i do this ) keep pressing and after 10sec i re-press power button. Then i can hear fan noise at full speed, dont have HDD connected so cant say if that would spin, First time i did this, heard some kind of error beeping sound, nothing after that, screen stays black.

    If someone could help me troubleshoot this? Thanks in advance!
     
  2. kassvein thread starter macrumors newbie

    Joined:
    Jul 27, 2015
    #2
    Update: 1 out of 3 times when i boot with smc bypass ( pressing power on before and after plugging magsafe ) i get beeping sound, 3 short 3 long 3 short noises. Apple suggests its corrupted EFi, with 3 long 3 short 3 long noises but mine is other way around so different problem? Cant find anywhere what this exact code means, i tried also pram reset and turning brightness up, only can hear fan with smc bypass, screen stays black.
    any ideas?
     
  3. kassvein thread starter macrumors newbie

    Joined:
    Jul 27, 2015
    #3
    Oh well, looks like this is sorted.
    It had 1x 2gb pc3-8500 ram stick on slot1, i swapped its place to slot 2 and got different error sound, 1 beep but continuous. When i moved it back to slot1 got same 3short-3long-3short beep sound.
    Replaced it with pc-10600 2gb stick first in slot1 and got 1 beep continuous error, after that i put it to slot1 and suprisingly it booted to white screen with question mark in box blinking, at that time i got different error sound, like tune or someting numerous times.
    It still worked with only bypassing smc, but when i got to white screen i reset pram with command and after that smc with removing battery and pressing power button for 5secs. After that suprisingly i got clean boot to white screen without need to bypass smc, power light started working aswell, its flickering on start. After that i put empty hdd to test if it spins and yes it does.
    Hope this helps someone gettings this error message.

    My friend said he dont have osx installation disc anymore and i tried Online recovery buttons on startup and nothing happens. I could see some efi firmware updates for 2010 mid model ( this one ) to recover lion fully online, but on stock settings this macbook should have snow leopard, he cant even remember which it was.

    Should i buy new snow leopard / lion installation disc OR maybe newer os x even?
    Or is there still someting i could try to get online recovery working ?
    thx
     
  4. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #4
    See my reply to your thread in the MacBook Pro forum.
     

Share This Page