Macbook Pro won't boot up, verify, or repair properly

Discussion in 'MacBook Pro' started by Mysterious, Oct 4, 2009.

  1. Mysterious macrumors newbie

    Joined:
    Jan 16, 2008
    #1
    My Mac won't boot. It goes to the screen with the apple and loading circle, but doesn't go past that. I've got WIN7 installed on bootcamp, so I can access that, but when I hold down option, MACINTOSH HD appears as EFI BOOT.

    I've used disc utility from my installation disc. When I've checked the permissions, it has failed. It also fails normal verification, saying "incorrect block count for file temp555244.".

    I was able to select repair disk once, but that failed as well. That would say "missing thread record (id=554666),
    keys out of order,
    rebuilding catalog b-tree,
    stopped repairing because filesystem verify or repair failed."

    Someone suggested I open terminal and enter "fscl_hfs -fy/dev/disk1s0" While it ran the comman and gave me a bunch of what seemed like options (r to repair btree, etc) i couldn't do anything from there. I tried entering "fsck and then /sbin/fsck -fy" as apple suggests on their site, but that did nothing. Any help in resolving this issue would be appreciated.

    Here are my specs:
    15" Macbook Pro, Mid 2009, 500GB HD, 4GB RAM, 2.8GHZ Processor Mac OS X (10.5.8)

    I was having similar problems a few days ago, when windows crashed as I was transferring files across partitions using macdrives. I had snow leopard when that happened, and reinstalled leopard. It worked fine after the reinstall, but the next day I started having these problems, which are similar in nature to the inital ones.
     
  2. airplaneman macrumors 6502a

    Joined:
    Jun 8, 2009
    Location:
    USA
    #2
    Have you checked the SMART history of your drive?
     
  3. suckaforamac macrumors newbie

    Joined:
    Mar 9, 2012
    #3
    My mac might have the same problem..

    How might one check this SMART history?
     
  4. gilgalad101 macrumors newbie

    gilgalad101

    Joined:
    Jun 27, 2006
    Location:
    south carolina
    #4
    MacDrive has a history of causing the OSX partition to become unbootable. This happened to me not too long ago. I fixed it by reinstalling Lion using the recovery partition, and I haven't had any issues since. Not sure what to do if you are still having problems after a reinstallation though.
     

Share This Page