Macbook Pro won't boot up

Discussion in 'MacBook Pro' started by carlili4190, Sep 29, 2011.

  1. carlili4190 macrumors regular

    Jun 8, 2010
    Hey guys I installed parallels a couple of days ago and decided that I didn't like it so I got rid of it(completely uninstalled it). I then went and tried to make a bootcamp partition and was successful. Turns out I didn't have a vista disk for the computer to boot from(just an .iso file). So I ended up deleting the partition for bootcamp. After all this happens my computer is now stuck in the boot screen(apple logo with the circle spinning).

    I took it to the apple store and they looked at it and "repaired the disk". The errors that came up were (Invalid File Count, Invalid volume directory count, and invalid volume free block count). Disk utility then goes to say "The volume Macintosh HD was repaired successfully". When the genius try's to boot it again same thing happens...Stuck at loading screen.

    I go home and reinstall Lion. Now the computer still gets stuck at the loading screen but if I force the computer off(Holding power) and turn it back on it will startup fine. I have to do this every time I want my computer on.

    I go back to disk utility and verify/repair disk and the same 3 errors come up again. Again the "The volume Macintosh HD was repaired successfully". I then tried to restore from a time machine backup and the same issue is happening.

    • Install Parallels--Don't like it so I uninstall
    • Make a bootcamp partition to find out I don't have disk's. Delete the partition
    • Take to genius and he "repairs" using disk utility. 4 Errors are listed. 1. Invalid Volume file count. 2 Invalid volume directory count. 3. Invalid Volume Free block count. 4.Volume Header needs minor repair.
    • After all the errors come up. The volume Macinstosh HD was repaired sucessfully
    • Reinstall OSX. Same errors occur
    • After OSX install computer gets stuck on apple logo... force turn off and turn it back on it will boot to desktop
    • Restore from time machine back up. Same errors occur with the computer still stuck on apple logo and have to force off to make it go to the desktop

    Any ideas on what I should do? I bought this computer back in July.
  2. carlili4190 thread starter macrumors regular

    Jun 8, 2010
  3. marshallman05 macrumors newbie

    Sep 29, 2011
    Heres the fix for this one.....


    ---------These steps will re-assign your MAC OSX partition to be the first bootable partition, Therefore booting into Mac normally.

    1. From the desktop, Click on 'System Preferences'

    2. Then Click on 'Startup Disk'

    3. You need to highlight then double click on the 'Mac HD - Mac OSX 10.7.1' (10.6 For Snow Leopard)

    4. Now Click on the 'Restart' button.

    5. This will now restart and set your Mac to boot correctly - YOUR FINISHED

    ---------If you haven't already deleted the second partition made by bootcamp - You will need to do this ** FIRST **

    1. Open up 'Finder', Then search for 'Disk utility' under the 'This Mac' Option (This will search the whole computer)

    2. Once on 'Disk Utility' highlight the first Hard drive in the list (For Example - 250.06GB HITACHI HTS5)

    3. You need select the BootCamp partition, and press " - " below to remove the Bootcamp partition, wait that to finish leaving empty space. Then you can expand the Macintosh partition.

    4. Use the slider option to restore the HD to its full capacity, Click 'Apply' Then 'Partition'

    5. This will now remove any other partitions on that HD - Your back to how you started !

    Hope this helps, any problems, drop me an email !

Share This Page