Macbook Pro Won't Boot via USB or SuperDrive

Discussion in 'MacBook Pro' started by dmw16, May 14, 2011.

  1. dmw16 macrumors regular

    Joined:
    May 14, 2011
    #1
    Sorry for starting a new thread when I have a similar one a few down, but I didn't want to get anyone confused and figured it'd be easier to tell the whole story in a new thread.

    Thursday night I went ahead to upgrade the 500GB drive that came in my mid-2010 MacBook Pro with a 120GB Intel Series 320 SSD.

    To do that I had:
    1 Intel SSD
    1 OWC DataDoubler - http://eshop.macsales.com/item/Other+World+Computing/DDAMBS0GB/
    1 OWC SuperSlim SuperDrive Enclosure - http://eshop.macsales.com/item/OWC/VLSS9TOPTU2/
    1 OSX 10.6.3 DVD

    I opened up my MBP as I had before when I installed RAM when I first bought it. I removed my existing hard drive and installed the SSD. I then installed the 500GB drive into the DataDoubler.

    I removed the optical drive and put the DataDoubler in place of the optical drive. Everything seemed fine up to this point.

    I booted the machine and it booted to the 500GB hard drive with zero issues. I was also able to see and format the SSD via Disk Utility.

    Wanting a clean install I put the OSX disk into the (now) external SuperDrive. The disc fired right up and I started the install. All the install files seemed to be copying fine, but when the computer went to reboot to continue the install it hung at the gray screen with the Apple Logo.

    I thought that was odd, but after waiting I did a hard restart and using the option key booted back to my 500GB drive. I checked the SSD and could see the install files and the DVD was still showing on my desktop.

    So I reformatted the SSD and started the install again. Same problem again.

    At this point I downloaded CarbonCopyCloner and had no issue cloning my 500GB drive onto my SSD and then booting from the SSD. So I confirmed both drives were working fine.

    Next I figured I'd eliminate the SuperDrive as the issue so I created a bootable USB drive to install OSX from. I did the clone, rather a verify disk (no issues), ran a repair disk (just in case), and ran a CheckSum to confirm the files were good (again no issues).

    The USB drive when plugged in pops up with the OSX installer. I run it, same issues. It starts installing but hangs at the Apple Logo when it comes time to reboot.

    I guess at this point I will need to go to the genius bar, but I am really at a loss for what could be going on. Any ideas on this?

    Thanks.
     
  2. ml.sail1 macrumors regular

    Joined:
    Aug 23, 2010
    Location:
    Pittsburgh
    #2
    10.6.6

    I forget exactly what version it is, but i believe the 2011 MBP's need a newer version of OSX such as 10.6.6 I think. That could be your problem.
     
  3. dmw16 thread starter macrumors regular

    Joined:
    May 14, 2011
    #3
    Could that be the issue even though I'm using the osx disc that came with my computer?
     
  4. harcosparky macrumors 68020

    Joined:
    Jan 14, 2008
    #4
    No, that should not be the issue if you are using the one that came with your computer.

    Have you tried removing the Data Doubler/HDD, reinstalling the optical drive and then reinstall the OS from the internally mounted optical drive?

    That is what I would have done when doing multiple upgrades.

    From the start:

    Step 1:
    Install SSD
    Install OSX to SSD

    Step 2:
    Removed Optical Drive
    Install Data Doubler/HDD


    Just saying that when a problem crops up, at least you know where to look.

    I've seen guys open machines, install a new HDD, RAM, and a second HDD in the optical drive slot and have problems but no idea which device caused the grief.
     
  5. pedrofan macrumors 6502

    Joined:
    Jun 9, 2008
    #5
    I had the same problem.

    My macbook pro doesn't boot from any bootable drive (superdrive in an external usb adapter, a bootable usb stick, etc).

    I tryed to boot and install windows 7 original disc from an external usb super drive adapter (i had an ssd with optibay) and it didn't work, i tryed it copying the disc image to a bootable usb, and the same.

    Finally I returned the superdrive inside the laptop and everything worked again.

    It must be the same with OSX installation...
     
  6. dmw16 thread starter macrumors regular

    Joined:
    May 14, 2011
    #6
    I returned the computer to stock and had the same issue with both the optical drive and USB drive.

    Going to the genius bar tomorrow.
     
  7. dmw16 thread starter macrumors regular

    Joined:
    May 14, 2011
    #7
    This turned out to be the issue. Thanks.
     

Share This Page