Macbook Pro won't connect automatically WiFi

ivoruest

macrumors 6502
Original poster
Jul 12, 2010
398
28
Guatemala
My Mac doesn't connect to my home Wifi automatically anymore. Do you know where o how do I manage to make it connect automatically again?? This began when I changed my Macs HDD (backup through Time Machine and then restore in the new one) but my old Mac was a Early 2008 Macbook Pro (non-unibody).
Is there something that is causing this problem due to the change of hardware?
 

iforbes

macrumors 6502
Dec 21, 2011
327
1
Try System Preferences->Network->Advance->Preferred Network (highlight current home wifi-fi (Network Name) and delete (-).

Now try to reconnect to your home wi-fi. Next, see if it connects automatically.
 

ivoruest

macrumors 6502
Original poster
Jul 12, 2010
398
28
Guatemala
Thanks for the reply! It didn't work. I goess its because of the router configuration or something. I have a Belkin router set up as access point but any of the computers connect automatically now. I'll check this and see if I can fix it.
 

Arelunde

macrumors 6502a
Jul 6, 2011
980
28
CA Central Coast
You might have to reset your router (turn off, wait briefly, turn back on). If that doesn't help, push the "reset" button on it.

I've had a lot of problems with my wifi printer (Canon MX870) dropping the connection. Spent hours toubleshooting and, as a last resort, reset the router. All better.
 

AdamHutchinson

macrumors newbie
Jun 4, 2012
5
0
Does the WiFi symbol have an "!" through it as mine did this a few months back and suddenly said that there was no hardware installed for the WiFi to be able to connect, all I did was leave it for a few hours or a day or 2 and it came back on, make sure you have not installed any virus' by mistake as this can happen easily and can affect things like this
 

Peafreen

macrumors newbie
Mar 14, 2004
25
1
MA
Wi-Fi Connection issue on older MacBook Pro w/Mountain Lion

Having issues w/ turning on Wi-Fi on a MacBook Pro after installing Mountain Lion on an older machine. Everything was working fine until I turned it off and restarted the machine. It can't find any wireless network. Plus when I go into System Preferences It won't even turn it on. If I connect it to ethernet for a while then it seems to refix itself until the machine is shut down and turned on again. Everything else seems to be find, software running ok, etc. Any ideas? Tx.

I'm using an Airport Extreme base station for wireless. I also just did the PRAM on start up, but thought I did that before as well. Is it an issue with Mountain Lion?
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.