MacBook Pro won't connect to 2Wire 2701 HG-B Router....

Discussion in 'MacBook Pro' started by austingunter, Mar 3, 2012.

  1. austingunter macrumors newbie

    Mar 3, 2012
    I've just taken over a sublease that has AT&T U-Verse DSL. The router is a 2Wire 2701 HG-B, and for some reason, my MacBook pro can't connect to the Internet through the router. My iPhone 4 has no problems, and my roommate's ThinkPad has no problems either. Those devices both connect without issues, so it's not a password problem.

    I've reset the router, left it unplugged for 2 minutes, checked the connections, all the normal troubleshooting. The problem is somewhere between the MacBook and the router. Even when I plug in directly to the router, I still can't get to the internet.

    More data: there is a coffee shop that I was at this week with a 2Wire router as well (don't know which kind, just know the name of the network) and there was the same issue.

    How the error manifests:

    The wireless icon shows that it's connecting to the network
    It can't connect and displays the "!" and says "Alert: No Internet Connection.."
    Network Diagnostics shows no connection to the internet

    MacBook Pro
    Mac OS X 10.7.3

    Thanks for your help!
  2. jaynone macrumors member

    Jan 2, 2012
    Those 2wire router/gateway units are absolute crap.

    Try changing the password to have a $ before it. That has helped in the past getting my mac on a router that it otherwise won't play nicely with.

    Worst case turn off the routing functions and buy a cheap router from somewhere.
  3. YJamie85 macrumors member


    Feb 27, 2012
    Did you set the channels to either 6 or 11? :) For the wireless I mean.
  4. Guru53 macrumors newbie

    Jan 14, 2012
    I've got a 2wire router/modem combo from AT&T U-Verse and I just turn off the wireless functionality and use my Time Capsule to broadcast the wireless signal. I've had no issues since setting this up and have had absolutely no downtime since the setup (approximately 2 months now).

Share This Page