Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.


macrumors 6502a
Original poster
Aug 26, 2011
This has been going on for the past few weeks now. When I close the lid, it doesn't sleep. When I click 'sleep'…it doesn't sleep.

I googled what could be the problem. I found an article that told me to go in to Terminal, Type in pmeset -g assertions . I clicked enter, and it says "PreventSystemSleep 1". Meaning a program or something is preventing my Mac from sleeping. How do I kill the program to enable my mac to sleep? What is a code i can type in to terminal to kill it? Nothing is open. All apps are closed.

One way I bypassed this was resetting my SMC. It works, but it's only temporary.
What can I do?

Here is the article. But it doesn't tell me the kill command.

Ofcourse, as soon as I post this I figure out the problem. Sorry everyone. Fixed it.


  • Screen Shot 2012-04-21 at 4.32.21 PM.png
    Screen Shot 2012-04-21 at 4.32.21 PM.png
    42.5 KB · Views: 672

Dangerous Theory

macrumors 68000
Jul 28, 2011
Looks like you've probably got printer sharing on. It keeps the printer driver active.

Edit: Didn't notice you'd already fixed it


macrumors newbie
Feb 12, 2010
I've had the same problem for 3 weeks, tried everything and just got help solving it - in my case there was simply a file in the printer queue waiting to print, and that was keeping the computer from sleeping! Deleted the file from the queue in printer preferences, printer went from "in use" to "idle" and my mini sleeps just fine :)
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.