Macbook Pro won't go to sleep.

Discussion in 'MacBook Pro' started by EmbraceTheOne, Apr 21, 2012.

  1. EmbraceTheOne macrumors 6502a

    Joined:
    Aug 26, 2011
    #1
    This has been going on for the past few weeks now. When I close the lid, it doesn't sleep. When I click 'sleep'…it doesn't sleep.

    I googled what could be the problem. I found an article that told me to go in to Terminal, Type in pmeset -g assertions . I clicked enter, and it says "PreventSystemSleep 1". Meaning a program or something is preventing my Mac from sleeping. How do I kill the program to enable my mac to sleep? What is a code i can type in to terminal to kill it? Nothing is open. All apps are closed.

    One way I bypassed this was resetting my SMC. It works, but it's only temporary.
    What can I do?

    Here is the article. But it doesn't tell me the kill command.
    http://www.adeepbite.com/lion-seems-having-insomnia-it-doesnt-sleep-easily/




    Ofcourse, as soon as I post this I figure out the problem. Sorry everyone. Fixed it.
     

    Attached Files:

  2. Dangerous Theory macrumors 68000

    Joined:
    Jul 28, 2011
    Location:
    UK
    #2
    Looks like you've probably got printer sharing on. It keeps the printer driver active.

    Edit: Didn't notice you'd already fixed it
     
  3. iforbes macrumors 6502

    Joined:
    Dec 21, 2011
    #3
    So what was the resolution?
     
  4. EmbraceTheOne thread starter macrumors 6502a

    Joined:
    Aug 26, 2011
    #4
    Look at above post.

    ^^^^

    If you need specifics or a walkthrough, let me know.
     
  5. claaariii macrumors newbie

    Joined:
    Feb 12, 2010
    #5
    I've had the same problem for 3 weeks, tried everything and just got help solving it - in my case there was simply a file in the printer queue waiting to print, and that was keeping the computer from sleeping! Deleted the file from the queue in printer preferences, printer went from "in use" to "idle" and my mini sleeps just fine :)
     

Share This Page