Macbook Pro Won't Load Internet pages via ethernet

Discussion in 'Mac OS X Lion (10.7)' started by tsam19, May 11, 2012.

  1. tsam19 macrumors member


    Aug 25, 2009

    I've recently upgraded to Lion 10.7.4 from 10.6.8 and was connecting to the internet and loading / browsing ok using an ethernet cable from the wall socket to the port on the mbp.

    I am using a keycom login account to access the internet ie you input a username and password to access the server to gain access to the internet.

    The issue is, I opened up the wifi and picked up the login page via a router and logged in, so I was receiving internet via wifi.

    Turned off the wifi and tried logging in back in through the ethernet cable and it's not playing ball !

    Checked the network preferences and the ethernet tab states its connected with an IP address, yet the internet pages will not load, the login page says there's an error ?

    I've set the service order with ethernet 1st, wifi 2nd etc

    If I have the ethernet cable plugged in and wifi on, nothing loads up, even though I get indication the IP address is there and wifi has located a router.

    If I unplug the ethernet, turn on the wifi, the internet is there, no need for me to login ?

    I don't have a router and I'm not sure whats kept my password and login details ??

    I've erased all network preferences of all found wifi networks, refreshed the DCHP but still the internet won't load via the ethernet cable.

    Ive tried this is the windows partition and it does the same.

    Any ideas on what I can do to solve the issue?

    Thanks :)
  2. agentphish macrumors 65816


    Sep 7, 2004
    I'd delete the contents of Macintosh HD/Library/Preferences/SystemConfiguration

    Reboot and see if you get it to work.

Share This Page