Macbook Pro won't recognize Android Phone

Discussion in 'MacBook Pro' started by Madgirl1801, Dec 27, 2011.

  1. Madgirl1801 macrumors newbie

    Dec 27, 2011
    My new Macbook Pro w/ OS X Lion won't recognize my android phone. However my windows PC will.

    The error i get is this "the inserted disk can not be read by this computer".

    Does anyone know what may be wrong? Is there any way that I can connect my android phone to my macbook pro so that I can transfer pictures?
  2. Spencer Reynen macrumors member

    Apr 3, 2011
    Bluetooth. Its not like Android phones are just going to show up in finder.
  3. ObuckiO macrumors regular

    Dec 9, 2011
    Maybe I helped

    It might be in the USB cable. I thought just because my charger was USB it would work, but no. I ran into this with other phones too. Verizon had just the cord. The Droid only comes with a charger cord...I think Windows computer's are more universal with adaptors though.
  4. vitzr macrumors 68030


    Jul 28, 2011
    The Solution

    All three of my Android phones connect with my MBP just fine.

    Make sure the phone's "connect to PC" setting is set to either Disk Drive or Media Sync then connect it to your Mac.

    You may need to restart the computer if it doesn't recognize the phone immediately.
  5. Madgirl1801 thread starter macrumors newbie

    Dec 27, 2011
    Macbook Pro won't recognize android phone

    I restarted my computer and tried a different USB cable but that didn't work.

    However, when I changed the USB setting on my Android phone from Mass Storage to Media Sync, My Macbook now recognizes my phone.

    Thanks a lot!!!
  6. snazzyiphoneguy macrumors member

    Dec 21, 2011
  7. thundersteele macrumors 68030

    Oct 19, 2011
    Maybe your phone is infringing on some Apple patents... that's why the MBP rejects it :D

    PS: I have an Android phone ;) Honestly right now I'm not sure if I ever connected it to the MBP.
  8. SurferMan macrumors 65816

    May 14, 2010
    South FL
    My GSII mounts fine on my Mac, I go to settings --> wireless & network --> USB utilities --> turn on mass storage .... then plug the usb in and it mounts as a drive and shows up on the desktop.

    If that doesn't work for you not sure what's wrong

    haha... disregard my post above, I didn't see this one lol
  9. theromz macrumors regular

    Aug 22, 2013
    I just use Android File Transfer and enable usb debugging, works just fine.
  10. eco7777 macrumors regular

    Dec 29, 2012
  11. Howard2k macrumors 68000


    Mar 10, 2016

    It was 4/7 years ago. I’m sure the parties appreciate your concern but have moved onto other phones by now.

Share This Page