Macbook Pro Won't Sleep

Discussion in 'MacBook Pro' started by judgejohn82, Oct 25, 2012.

  1. judgejohn82 macrumors member

    Joined:
    Jul 2, 2010
    Location:
    Glasgow, Scotland
    #1
    Hey guys,

    As of this morning, my 13" mid 2010 MBP (running 10.8.2) refuses to sleep, either by closing the lid or choosing sleep from the Apple menu.

    Having googled this, I was advised to run pmset - g assertions from Terminal.

    I did this, and the output is displayed below.

    However none of the suggestions I have found (deleting outstanding print jobs, resetting SMC etc) have worked.

    If anyone can help I'd be extremely grateful!



    Last login: Thu Oct 25 15:16:24 on ttys000
    *****:~ *****$ pmset -g assertions
    25/10/2012 15:17:46 BST
    Assertion status system-wide:
    PreventUserIdleDisplaySleep 0
    PreventSystemSleep 0
    PreventUserIdleSystemSleep 0
    ExternalMedia 0
    UserIsActive 0
    ApplePushServiceTask 0
    BackgroundTask 1

    Listed by owning process:
    pid 188(helpd): [0x0000000c00000161] 00:01:29 BackgroundTask named: "com.apple.helpd.sdmbuilding"
    pid 74(mds): [0x0000000c0000013a] 00:01:39 BackgroundTask named: "com.apple.metadata.mds"

    Kernel Assertions: 0x0132
    * Kernel Assertion ID = 500
    Created At = 01/01/1970 01:04:11 GMT+
    Modified At = 01/01/1970 01:00:00 GMT+
    Owner ID = 0xffffff802f8cf000
    Level = 0
    Assertions Set = None (4)

    * Kernel Assertion ID = 501
    Created At = 01/01/1970 01:04:12 GMT+
    Modified At = 01/01/1970 01:00:00 GMT+
    Owner ID = 0xffffff802f8d2000
    Level = 0
    Assertions Set = None (4)

    * Kernel Assertion ID = 502
    Created At = 01/01/1970 01:05:03 GMT+
    Modified At = 25/10/2012 15:22:14 BST
    Owner ID = 0xffffff802f8bb000
    Level = 255
    Assertions Set = None (4)

    * Kernel Assertion ID = 503
    Created At = 01/01/1970 01:05:14 GMT+
    Modified At = 01/01/1970 01:00:00 GMT+
    Owner ID = 0xffffff802f867000
    Level = 0
    Assertions Set = None (4)

    * Kernel Assertion ID = 504
    Created At = 25/10/2012 15:23:11 BST
    Modified At = 01/01/1970 01:00:00 GMT+
    Owner ID = 0xffffff802f98cb00
    Level = 255
    Assertions Set = None (128)
     
  2. judgejohn82 thread starter macrumors member

    Joined:
    Jul 2, 2010
    Location:
    Glasgow, Scotland
    #2
    Also in a slight development, the MBP now occasionally (but not always) sleeps. However, when I reopen the lid, it automatically resumes the last app I was using, instead of prompting me for my password (which is what I want to happen)
     
  3. judgejohn82 thread starter macrumors member

    Joined:
    Jul 2, 2010
    Location:
    Glasgow, Scotland
    #4
    Thanks for the quick reply.

    However, none of them have worked.

    I have deleted and reinstalled my one printer that I use, and do not use gfxcardstatus as I have integrated graphics only on my MBP.

    I have just tested the problem again, and when I select "Sleep" from the :apple: menu the screen turns off OK. However, when I wake it by pressing a key, it reopened with Safari, instead of prompting me for my user password as it used to.

    It looks as if it may be something to do with the mds process, but even if I kill it using Activity Monitor, it install restarts with a new pid.
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #5
    System Preferences > Security > General > Require password after sleep or screen saver begins. (is this checked?)
    The mds process is the metadata server, which serves all clients of the metadata APIs, including Spotlight. It's not the source of your issue.
     
  5. judgejohn82 thread starter macrumors member

    Joined:
    Jul 2, 2010
    Location:
    Glasgow, Scotland
    #6
    Thanks so much, that has sorted the problem.

    You are a legend!
     
  6. RedRaven571 macrumors 65816

    RedRaven571

    Joined:
    Mar 13, 2009
    Location:
    Pennsylvania
    #7
    Hi judgejohn82,

    I'm having the exact same sleep issue. Ran pmset -g assertions and the same 2 processes are running.

    There seems to be a gap between when you said basically nothing worked and when you checked require password after sleep.

    Did you do anything else that corrected the issue?

    Thanks,
    Joe
     
  7. JosephBergdoll macrumors 6502

    Joined:
    May 7, 2009
    Location:
    NYC
    #8
    I too have been having this issue, along with seemingly gazillions of others on the Apple support community. I've found that holding the eject button on the keyboard wakes it up.
     
  8. DisplacedMic macrumors 65816

    Joined:
    May 1, 2009
    #9
    did you ever resolve this? i am having the same problem when i close the lid.
    i can make it sleep manually, just not by closing the lid. can't figure it out
     
  9. anthonyrs macrumors newbie

    Joined:
    Sep 16, 2013
    #10
    Same Same

    I also am suffering from the same issue. This is ridiculous, I have done everything humanly possible to try to fix the issue. I reset PRAM and SMC, checked terminal for processes blocking sleep, downloaded various sleep-aides plugins and programs, nothing works. Every time i try to sleep, my macbook seems to wind down immediately (fans stop buzzing, screen turns black, 2 seconds of silence and then VROOM its back on and fans are even louder than before).

    I have a mid-2009 Macbook Pro.

    Anybody find an issue to this problem?
     
  10. KUguardgrl13 macrumors 68020

    KUguardgrl13

    Joined:
    May 16, 2013
    Location:
    Kansas, USA
    #11
    Unfortunately I can't give you an answer, but I can sympathize. I also have the mid-2009 MBP and have the opposite problem where it sometimes won't wake up when I press a keyboard button or the trackpad. The only answer I've found is to hold down the power button and restart, but that wears on my hard drive.

    Really wish Apple could find solutions to issues that have been around for years!!
     
  11. johnsawyercjs macrumors member

    johnsawyercjs

    Joined:
    Feb 27, 2007
    #12
    Some more possible solutions

    The OP's pmset listing includes a mention of the process "helpd", and its background task "sdmbuilding". This has something to do with building a folder associated with help data for applications, and normally sdmbuilding quits when it's done. However, it can get stuck, constantly running, preventing a Mac from sleeping. Sometimes it can be jogged back to normalcy by force-quitting from its parent helpd process, using Activity Monitor. helpd will relaunch immediately, but hopefully its sdmbuilding task will now run properly. If that doesn't help, you could also try trashing the two plist files associated with helpd (both are named com.apple.helpd.plist). One is at System/Library/LaunchAgents, and the other is at ~/Library/Preferences. There are also some helpd cache files in the folder at ~/Library/Caches/com.apple.helpd that you can trash.

    There are also some helpful suggestions at
    https://discussions.apple.com/thread/4888747?start=0&tstart=0

    When I had a problem where my Macbook wouldn't automatically sleep when the display lid was open, I found that the fix was suggested in that thread, to use Activity Monitor to kill the process named "powerd". As with helpd, it automatically relaunches when it's killed, but in a healthier state.
     

Share This Page