MacBook Pro won't start - Linux ate my computer.

Discussion in 'MacBook Pro' started by Molecule, Jun 2, 2011.

  1. Molecule macrumors regular

    Joined:
    May 19, 2010
    #1
    The other night I decided to install Linux (Ubuntu 11.04) alongside OS X. I created the partitions in Boot Camp Assistant (or whatever it's called), restarted the computer, and slotted the disk in. Now, I've installed plenty of Linux systems before, but never alongside OS X. I tried to set the partitions up manually in the installer, but it was being somewhat... argumentative. It was getting late, and I had to get up and go to work in the morning, so eventually I gave in and clicked the "Install Ubuntu alongside Mac OS X" option. This seemed to go okay... at least I thought went okay, anyway. Turns out I was wrong. It seems to have mangled some of the existing partitions, and now my computer won't start. When I turn it on, I can hear the hard drive start up, and the CPU start to think (or whatever that ticking noise is), but there is no Macintosh Bong. And the screen is black. And nothing seems to happen. I'm yet to try leaving it on overnight to see if it gets somewhere, but I'm not hopeful.

    It appears that the hard drive has been rendered more or less unusable for the time being (at least until I can format it). I'm planning to replace the hard drive, but I don't have enough money to do that until early next week... so between now and then, I'm kinda screwed. I'm assuming it's the hard drive that's the problem, since that's the only thing that's changed, and it all this started as soon as I shut down post-Linux installation.

    This brings me to my question: does anyone here know of a way to fix this (preferably for free) without swapping out the HDD? I don't live anywhere near an Apple Store, so the Genius Bar is out of the question, and other computer technicians generally charge money.

    All suggestions are welcome :)



    Molecule
     
  2. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #2
    You should still get the startup chime and something on the screen even if the hard drive isn't bootable. Try holding Cmd-Opt-P-R at boot and see whether it chimes then.
     
  3. gullySn0wCat macrumors 6502

    Joined:
    Dec 7, 2010
    #3
    Try installing rEFIt onto a USB key and see if it will let you boot from either partition.
     
  4. Molecule thread starter macrumors regular

    Joined:
    May 19, 2010
    #4
    Thanks, I'll try that.
    Oh and by the way, the screen stays black when I turn it on rather than going white or grey, in case you were wondering.
     
  5. Molecule thread starter macrumors regular

    Joined:
    May 19, 2010
    #5
    I'd try that, but I don't have anything to download it onto (I'm on a public terminal right now, and I don't have a thumbdrive on me).

    Also, the screen doesn't appear to be working, so I mightn't be able to see what I was doing.

    Thanks anyway :)
     
  6. Molecule thread starter macrumors regular

    Joined:
    May 19, 2010
    #6
    IT LIVES!

    I managed to get the computer to start, and have formatted the drive and installed Ubuntu on it (for expediency purposes). It still takes a few attempts to turn the machine on, but other than that everything is working just fine.

    This also means I don't need a new hard drive. Yay!


    Thankyou to everyone who posted suggestions. :)



    Molecule
     

Share This Page