MacBook Pro won't start up

Discussion in 'MacBook Pro' started by puglybug23, Nov 23, 2014.

  1. puglybug23, Nov 23, 2014
    Last edited: Nov 23, 2014

    puglybug23 macrumors newbie

    Joined:
    Nov 23, 2014
    #1
    I have a mid-2012 MacBook Pro. It has the latest update before Yosemite on it, at least the last time it was working...

    Two days ago I knew I was going to be gone for a day so I shut down my MacBook Pro, which was working 100% perfectly, unplugged it because it had 100% battery, and left it on my desk where it always sits. Today, I can't get it to start up. It does turn on, and the light on my charging cord tells me the battery is still 100%, but after about 20 seconds of trying to start up my files it unexpectedly shuts off.

    There is a loading bar, which I have seen in another thread here is something with Yosemite, so I'm wondering if maybe it's trying to do something with the update and therefore can't start up my files.

    I am currently running the hardware test on the advice of a different thread (I held down D while starting up), but that thread had a slightly different problem than mine, I'm pretty sure. I'll say what the results are when it finishes.

    I do have a back up, but it is a few days old and I would prefer to not have to reset my stuff.

    I did also make an appointment at an apple store, but the earliest I can get in is next Saturday, and I really can't afford to go a week without my laptop in my college classes.
     
  2. puglybug23 thread starter macrumors newbie

    Joined:
    Nov 23, 2014
    #2
    The test made it nearly to the end and then sat still for two hours. I tried to stop the test at that point, but the mouse wouldn't move and it seemed that the computer had become unresponsive, so I shut it down.

    I tried turning it on again, and this time I counted seconds to see exactly what it was doing.

    For twenty seconds, the loading bar is there, and it gets maybe 1/16 th of the way across, then the bar disappears and it's just the apple logo and the gray swirling circle. At 30 seconds the computer shuts off.
     
  3. niteflyr macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    Southern Cal
    #3
    MacBook Pro won't start up

    Try booting in safe mode.

    http://support.apple.com/en-us/HT201262

    If no luck CMD+R boot to recovery and try disk and permissions repair from Disk Utility. You can also reinstall OSX from recovery. It will install over existing OSX and leave data intact.
     
  4. puglybug23 thread starter macrumors newbie

    Joined:
    Nov 23, 2014
    #4
    I couldn't get safe mode to boot, so I went on to verify the disk. It said it needed to be repaired, but when I tried to do so, it said that it was unable to repair it. Then I tried to reinstall Mavericks (since apparently that's the latest thing and what it wanted to restore) but it now tells me that I cannot install it on Macintosh HD. Which is my computer's hard drive. I did check the Internet but the connection is fine. It looks like I'll just have to wait until my appointment next weekend to have this resolved :/ thank you for trying to help, though.
     
  5. poiihy macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #5
    Maybe it is a bad hard drive. This problem does not happen when you are in internet recovery, right? If so then it is almost certainly your hard drive or hard drive cable.
     
  6. puglybug23 thread starter macrumors newbie

    Joined:
    Nov 23, 2014
    #6
    I'm not sure how to do Internet recovery, so I don't know about that.

    But that does seem possible. If it's the cord, I'm going to be a bit upset with apple. In the last year that cord has had to be replaced four times already. They keep reassuring me that I'm not doing anything to cause it, which almost makes it worse. I trust Macs, I do, but my laptop can't continue to do this. It's still under AppleCare plus for another 6 months and then 3 years are up.... If the problem is once again the cord, do you think this is worth complaining to them about further? Otherwise my laptop works fine.
     
  7. puglybug23 thread starter macrumors newbie

    Joined:
    Nov 23, 2014
    #7
    I finally got my computer back and it (seems) to be working fine. I thought I would post here to say what it ended up being:

    It was a bad hard drive and bad hard drive cable. Both apparently were having some trouble. Luckily it was a free repair for me because my computer is still covered by AppleCare.

    Thanks everyone for the help.
     

Share This Page