Macbook pro - won't wakeup (black screen).

Discussion in 'MacBook Pro' started by canhaz, Mar 27, 2012.

  1. canhaz macrumors regular

    Joined:
    Jan 17, 2012
    #1
    Hi All

    I don't know why but often when my machine has been in my bag a while, I take it out and it just won't wakeup.

    The white power led in the front is on, and the screen is just black. Sometimes the screen will be very very faintly dim and not responding.

    Any ideas how to solve this? I've tried resetting SMC.

    How could I troubleshoot or figure out whats going on?

    Thanks for any pointers...

    ----------

    I think it might be the same as MacMedic. I also have a CinemaDisplay with USB and I think it might occur if I take it out my bag and plug it in to the thunderbolt port without opening it up.

    Will try test some more...
     
  2. canhaz thread starter macrumors regular

    Joined:
    Jan 17, 2012
    #2
    FWIW, and in case anyone else is having an issue.

    I've done two things now:

    • Disabled automatic graphics switching (System preferences -> Energy)
    • Unplugged the Logitech MX Anywhere USB receiver from the Thunderbolt display and plugged it directly into the MBP.

    Will let you know if this fixes anything.
     
  3. thisisnk macrumors newbie

    Joined:
    Mar 28, 2012
    #3
    i've been having the same problem. Even when the computer goes to sleep while the lid is open, I tap on any key on the keyboard, the computer itself wakes up but the screen remains black (or sometimes very dim).
    everytime this happens, i have to hard reboot.
    it seems almost impossible to find a solution for this...at least for now.
     
  4. shardey macrumors 6502a

    shardey

    Joined:
    Jan 28, 2010
    #4
    I used to have this problem and thought it was my hyperx 1866 memory. I took it out for a month just to put it back in with no problems. I reinstalled lion 3-4 times, I tried snow leopard, no luck. Keys worked, such as the keyboard brightness and the sound.

    Have you installed any different applications recently? Do you have a SSD?
     
  5. canhaz, Mar 29, 2012
    Last edited: Apr 14, 2012

    canhaz thread starter macrumors regular

    Joined:
    Jan 17, 2012
    #5
    Solved!

    As suspected, it was caused by the Logitech Universal wireless receiver! Can you believe it?

    So for anyone else having issues, a suggestion would be unplugging ALL devices from the Thunderbolt display and seeing if that helps.

    Specifically moving the Logitech Wireless receiver from being in the USB port on the back of the Thunderbolt display, to rather being located in the Macbook Pro USB port, helped the situation.

    ----------

    Yeah I'm always changing stuff around and installing, hence it's hard to track these issues down ! :p
     
  6. shardey macrumors 6502a

    shardey

    Joined:
    Jan 28, 2010
    #6
    Well that must explain my situation too, as I use the MX performance mouse and have definitely had that program installed that came with it.
     
  7. canhaz thread starter macrumors regular

    Joined:
    Jan 17, 2012
    #7
    Furthermore, I also found the Fitbit was causing problems (again USB).

    https://discussions.apple.com/thread/3220091?start=0&tstart=0

    Code:
    Backtrace (CPU 1), Frame : Return Address
    0xffffff82139fbbe0 : 0xffffff8000220702 
    0xffffff82139fbc60 : 0xffffff80002c266d 
    0xffffff82139fbe00 : 0xffffff80002d7a1d 
    0xffffff82139fbe20 : 0xffffff7f80cec728 
    0xffffff82139fbf40 : 0xffffff800063c071 
    0xffffff82139fbf70 : 0xffffff800023db2c 
    0xffffff82139fbfb0 : 0xffffff8000820057 
          Kernel Extensions in backtrace:
             com.silabs.driver.SiLabsUSBDriver(1.1.2)[C467B101-3C6D-1FB2-7A79-0C00AC4BEC65]@0xffffff7f80ce9000->0xffffff7f80d07fff
                dependency: com.apple.iokit.IOUSBFamily(4.5.8)[1FEB88C1-AD15-3AEF-8379-CA51810FD38E]@0xffffff7f8086b000
                dependency: com.apple.iokit.IOSerialFamily(10.0.5)[9EF0ADC7-7D42-38C6-9BD8-185CB717F80E]@0xffffff7f80bce000
    
    Uninstalled it.
     
  8. greatgonzo macrumors newbie

    Joined:
    Jun 13, 2009
    Location:
    Melbourne, Australia
    #8
    That doesn't fix my problem. I have nothing plugged into thunderbolt, in fact nothing connected at all. My computer is acting same as described, and can't be woken from sleep. When I force a reboot, screen goes black.
    Any other ideas?
     

Share This Page