Macbook problem admin gone CD wont boot

Discussion in 'Mac Basics and Help' started by lilwel, Sep 27, 2009.

  1. lilwel macrumors newbie

    Joined:
    Sep 27, 2009
    #1
    I have been looking for weeks to try and fix my problem

    I installed updates onto my mac and it removed my admin privileges, I called apple my mac was exactly one day past its garuntee so they could not help me, 2 days later my keyboard stopped working.


    Basically i want to add a new admin account using my mac disk.

    But it wont boot, i have tried holding c as it starts up, holding c as i turn it on, i have tried apple+s nothing seems to be working i cant select a boot disk as i have to type in the admin and my admin has been put to a standard user.

    Any help would be greatful its bugging me as i can not install or uninstall anything or even run a restore on my external hardrive

    i am using

    mac os x 10.5.7

    processor - 2.1 Ghz Intel core 2 duo
    Memory - 1GB 667 Mhz DDR2 SDRAM
     
  2. iBookG4user macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #2
    Wait, does the keyboard work or doesn't it? And have you tried going to System Preferences > Accounts > "Allow user to administer this computer"?
     
  3. lilwel thread starter macrumors newbie

    Joined:
    Sep 27, 2009
    #3
    i have a usb keyboard attached to it sorry the most obv thing i forgot to mention :)

    I have gone to the accounts section and the allow user to administer this computer is shadowed out so i cant click on it
     
  4. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #4
  5. lilwel thread starter macrumors newbie

    Joined:
    Sep 27, 2009
    #5
    problem is the DVD wont boot i have tried to get it up but it just wont boot
     

Share This Page