Macbook Process using 100% CPU

Discussion in 'MacBook' started by a104375, Oct 28, 2009.

  1. a104375 macrumors 6502

    a104375

    Joined:
    Oct 8, 2007
    Location:
    Matamoras, PA
    #1
    I just got a used macbook and restored it from my time machine backup and I had a problem with duplicate fonts causing fontworker to run all the time slowing down the computer but at the same time some process called "genatsdb" under user "_atsserver" and usually there's up to 3 of these processes running and it ends up using 60% cpu each slamming my C2D to 99% which really slowed things down. Anyone have an idea of how to fix this problem? For the time being I've just force quit the process in question so I can actually use the computer.
     
  2. poxod macrumors newbie

    Joined:
    Aug 11, 2004
    #2
    same problem

    I had the same problem after I tried to move a bunch of fonts from my old PB to my new MBP running Snow Leopard. I think it has something to do with ATS not being able to reconcile duplicate or 'improperly' installed fonts. fontd and genatsdb would eat up processor cycles until eventually the Finder crashed and could not be relaunched. After a hard restart, OSX wouldn't even load. Give these instructions a try:

    http://blog.lo-fi.net/2009/10/upgrade-to-snow-leopard-freezes-at-boot.html

    Addendum to the above instructions - this solution only worked after I removed all of my fonts and font collections from both Library/Fonts/ and [user]/Library/Fonts/

    You should be able to add back any non-standard fonts with Font Book, but I haven't tried that yet (still just happy to have my laptop back and not ready for another weekend of troubleshooting)

    hope it helps, let me know if you learn any more.
     

Share This Page