Macbook Pro's Fan Runs unusually loud after sleeping

Discussion in 'MacBook Pro' started by Spencie, Sep 26, 2012.

  1. Spencie macrumors regular

    Spencie

    Joined:
    Aug 17, 2011
    Location:
    The Mothership
    #1
    I put my 2011 Macbook Pro 15 inch to sleep, and 10-20 mins later the fan runs very very loud. I open the mac and the only applications I have running are Chrome, Itunes, and Word. Is this normal? Also when I run a video chat, the fan is extremely loud. My mac has i7 processor with 8gb RAM. Maybe I installed the RAM wrong?


    Any response would be appreciated
    [​IMG]
     
  2. mrsir2009 macrumors 604

    mrsir2009

    Joined:
    Sep 17, 2009
    Location:
    Melbourne, Australia
    #3
    Hi there Spencie,

    Resetting the SMC would be the best thing to try. To reset it simply:

    1. Shut down the computer.

    2. Plug in the MagSafe power adapter to a power source, connecting it to the Mac if its not already connected.

    3. On the built-in keyboard, press the (left side) Shift-Control-Option keys and the power button at the same time.

    4. Release all the keys and the power button at the same time.
    Press the power button to turn on the computer.

    Good luck :)
     
  3. mgartner0622 macrumors 65816

    mgartner0622

    Joined:
    Jun 6, 2010
    Location:
    Colorado, USA
    #4
    As others have said SMC should help. I'm also going to chime in that the RAM shouldn't have an affect on the fan speeds, unless you were actually running out of it.
     
  4. tidewatcher, Dec 14, 2012
    Last edited: Dec 25, 2012

    tidewatcher macrumors newbie

    Joined:
    Dec 14, 2012
    Location:
    Cambridge
    #5
    It may be a GPU problem

    It started happening on my machine recently and the timing approximately co-incided with my interest in webgl. I am not aware of any system updates that I could blame this on. It could have been just a co-incidence, but it lead me to a solution.

    The problem was that during the last couple weeks, the machine would go to sleep normally but wake up with both fans going full speed. Sometimes, putting it back to sleep and waking it up again helped reset the fans. Today, doing so did not help and I looked further. I could not afford to reboot the machine (too much going on), so I ignored the advice to reset the SMC and kept looking for causes.

    I noticed that the GPU temperature (Graphics Processor Heatsink) was reported at -128°C (negative temperature; probably a code for "unknown"). That makes sense: if the temperature is not known, better work the fans up, just in case it is high. So it was clear to me that it was not a fan speed issue but rather a GPU subsystem issue. What could have broken it? I recalled that when I started playing with webgl, I had to enable it in Safari, and I recalled asking myself why wouldn't it be enabled by default. I suspect Apple considers it unstable. It could be that, but I don't know enough to be sure. The following sequence returned fan speed to normal:

    1. Disalble webgl in Safari (Develop -> Enable WebGL)
    2. Quit Safari
    3. Go to sleep.
    4. Wake up (after a few seconds)

    Update: webgl probably doesn't have anything to do with it. My machine woke up several more times with fans at high speed after I had disabled webgl in Safari, but I was able to reset fans just by quitting Safari and going to sleep. Safari is still a suspect because going to sleep without quitting it did not help.
     

Share This Page