Macbook- Red light in Headphone - Sound messed up

Discussion in 'MacBook' started by dawnraid, Feb 4, 2009.

  1. dawnraid macrumors regular

    Joined:
    Nov 9, 2007
    #1
    So I was just listening to some music through some speakers on my old 1.8ghz cd macbook and then I unplugged the cable from the headphone jack and noticed that there was a red glowing light coming from the headphone jack. Now my sound is messed up, sound works properly only when something is plugged into the headphone jack. Nothing will play through the internal speakers when i try to adjust the volume with nothing plugged in I get this. Has this happened to anybody else, any solutions?
     

    Attached Files:

  2. mikethemovie macrumors member

    Joined:
    Feb 28, 2008
    #2
    I had this problem to.. Cant remember what laptop it was..

    Try Google.. There is much to find about this.. I thought something wasnt in the good place.. Or something.. Macgoogle..

    It went away after a while..
     
  3. ikkeson macrumors newbie

    Joined:
    Sep 9, 2008
    #3
    I assume that for som reason the digital output is activated. What happens when you reboot the mac? Does the red light keeps glowing?
     
  4. dawnraid thread starter macrumors regular

    Joined:
    Nov 9, 2007
    #4
    I did some research on google. Apparently a switch got stuck inside the headphone jack, slowly inserting a headphone cable into the jack fixed the problem. Thanks and hopefully this doesnt happen again /fingers crossed
     
  5. ajthomason macrumors 6502

    #5
    Just to let you all know, the red light is used on all apple products (excluding iPods) to show when headphones are being used - if you have an Airport Express, try telling iTunes to play music to it without any speakers plugged in and you'll see what I mean.
     
  6. Sesshi macrumors G3

    Sesshi

    Joined:
    Jun 3, 2006
    Location:
    One Nation Under Gordon
    #6
    Cool! Does the red light sweep from side to side?
     
  7. Chase817 macrumors member

    Chase817

    Joined:
    Jul 6, 2008
    #7
    I've had this problem! All you have to do is jam a few items in there, as in the back of a match, the small end of a paintbrush etc. I thought it was a joke, but it actually worked. The small end of a paint brush worked for me. Google it and you will see what I'm talking about.
     
  8. Jack Flash macrumors 65816

    Joined:
    May 8, 2007
    #8
    No, actually the red light is for the purpose of digital audio. It is supposed to be activated only when a mini-TOSLINK connector is inserted.
     
  9. ajthomason macrumors 6502

    #9
    Really? I didn't realise that you could get a TOSLINK connector that uses the same size port as a headphone cable (I've only ever seen the big ones on the Apple TV / PS3 etc.). You learn something new every day... :)
     
  10. brendan.leo macrumors newbie

    Joined:
    Nov 13, 2009
    #10
    3.5mm toslink connectors exist, they are longer than a 3.5mm TRS connector. On the Apple products that support digital audio out, the optical unit is in the headphone jack. It sits further back in the jack though, to accommodate the longer toslink connector, and to prevent damage from the metal tip of a TRS connector.
     
  11. Cloud999 macrumors newbie

    Joined:
    Nov 8, 2011
    #11
    This will fix your issue with the sound

    Shut down the Mac computer and then turn it back on, immediately hold down these four keys at the same time for 10 seconds "command, option, r, p" your mac computer will restart couple of times show will here the restart sound. now release the keys and let it restart. Your problem will be solved.

    This technique is a robust restart of the computer, this sound problem happens when we overload the mac system, this technique release the pressure of the system. "Do not attempt to do this to many times it could damage the system as well"
     
  12. logana macrumors 65816

    logana

    Joined:
    Feb 4, 2006
    Location:
    Scotland
    #12
    Did you join to post this ?

    Resetting PRAM will NOT do anything about this problem......

    It is a normally a physical problem inside the headphone jack so your technique will not change anything.......
     
  13. biohead macrumors 6502

    Joined:
    Jun 18, 2010
    Location:
    West Drayton, UK
    #13
    Looks at date of original post... 2 years ago :rolleyes:

    Anyway... it's a sticky switch inside the jack that causes this problem. A PRAM reset, if it fixed it, would just be coincidence.
     
  14. AppleFanatic10 macrumors 68030

    AppleFanatic10

    Joined:
    Nov 2, 2010
    Location:
    Encino, CA
    #14
    I've had this problem a couple of times. I just restarted my computer and it went away...

    EDIT: Didn't realize that this thread was so old. Nevermind.
     

Share This Page