Macbook refuses to shut down

Discussion in 'MacBook' started by cleanup, Sep 4, 2008.

  1. cleanup macrumors 68030

    cleanup

    Joined:
    Jun 26, 2005
    Location:
    Toronto
    #1
    I've noticed over the life of my MacBook that over the past 8 months or so, it usually refuses to shut down or restart at times. I click it in the context menu and nothing seems to happen. Some apps quit, some don't, then it gives an error saying that such and such application refused to quit, and thus shutdown/restart was aborted. This happens even though the application in question had quit and is no longer running. Eventually, I've manually exited every application, and nothing. Relaunching the Finder no longer works. It just quits. The menubar disappears, but the dock remains, and the system sits there doing nothing.

    The only way to power the computer down is to hard shutdown or pull the battery.

    Any ideas? It's extremely frustrating, and probably unhealthy for the computer for it to never have a proper shut down.

    It seemed to restart fine after the last major update I did.
     
  2. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #2
    It'd really help if you read system.log using Console to see what your Mac is hanging on when it tries to restart.
     
  3. cleanup thread starter macrumors 68030

    cleanup

    Joined:
    Jun 26, 2005
    Location:
    Toronto
    #3
    how do i go about doing this?

    [Edit] Never mind. Gotcha. I'll see if I can reproduce the problem.
     
  4. cheeseadiddle macrumors regular

    Joined:
    Aug 29, 2007
    #4
    Same problem, no relief

    You know... I've been having the same problem with mine.

    Typically what happens is that a program will hang. No program in particular... I've had it happen with Finder, iTunes, Safari, Acrobat, Mail, Garageband, Word, Text Edit... you name it. You get the spinning beach ball. After a minute you try to quit the program, but no luck. Then you try Force Quit, with no luck. You can't restart because the shut down process stops and tells you that _____ is not responding. So the only way out of this is to force a shut down with the power button.

    Then on restart, you get to the blue screen and it hangs there. About 4 to 5 minutes. Then all the sudden it switches back to the gray screen and promptly back to the blue screen where in what is expected as a normal amount of time, the login options appear. It always refuses to see my LaCie FW400 external drive on this restart too. I have to unplug and plug it back in three or four times for it to finally be mounted.

    It happens exactly this way every time. Probably about five times a week. I've tried re-installing OSX and migrating my information over from my iMac, I've tried an erase/install of OSX. Both have had no effect on the problem.

    So does anyone think this is an OSX problem, or a hardware problem? I've taken this MacBook in for repairs three times.

    1. Optical Drive
    2. Optical Drive, Logic Board and Top Case [sent to repair depot]
    3. Top Case

    I'm getting quite tired of this problem. I'm wondering now if I should just make another genius bar appointment?
     
  5. Chappers macrumors 68020

    Chappers

    Joined:
    Aug 12, 2003
    Location:
    At home
    #5
  6. cheeseadiddle macrumors regular

    Joined:
    Aug 29, 2007
    #6
  7. dadeef macrumors member

    Joined:
    Jun 6, 2008
    #7
    You just have to delete:
    /Library/Preferences/com.apple.loginwindow.plist (system wide)
    ~/Library/Preferences/loginwindow.plist (your user)
    ~/Library/Preferences/com.apple.loginwindow.plist (your user)


    I fixed it today but I'll check if the problems still exists for me. It worked once
     

Share This Page