Macbook refuses to start

Discussion in 'MacBook Pro' started by teapot6356, Nov 12, 2014.

  1. teapot6356 macrumors newbie

    Joined:
    Feb 11, 2010
    #1
    Hi I have a mid 2010 25" Macbook Pro with 6 GB RAM and a 1TB hard drive. All was fine until a couple of days ago. I wiped the hard drive and since the it refused to be recognised, I removed the drive to investigate it further sing my Mac Pro. It was not recognised So I formatted it and it came back as 1PB (I wish). When I tries to erase it, it failed stating that the last block could not be read. So I replaced the Hard drive with one I created on my Mac Pro and proved the bootability of it on the mac pro. I then replaced it in the macbook. Since then when try to boot all I get is a light grey screen and after about 1 or 2 minutes a flasshing folder icon and a question mark.
    I have tried all the keyboard startup assists and tried booting from a Mzc OS install disk and Disk Warrior and Tech Tool Pro all to no avail. I have seen a video sugesting it may be the hard drive data cable, could this cause the complete inability to boot?
    Many thanks for any assistance
     
  2. Brian Y macrumors 68040

    Joined:
    Oct 21, 2012
    #2
    Yep, most likely cause is the SATA cable. They're a bit of a pain.

    If you pop to your local apple store they may have one kicking around, else they're about $15.
     
  3. teapot6356 thread starter macrumors newbie

    Joined:
    Feb 11, 2010

Share This Page