Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

desertman

macrumors 6502a
Original poster
Jul 14, 2008
673
28
Arizona, USA
I have a "Mid 2010" MacBook with OS X 10.11.5 on it. Its Energy Saver preference is set to never sleep when connected to a power adapter.

However, when I leave this MacBook alone for some time it reverts on its own back to the login screen.

How can this be prevented? I don't want the MacBook to sleep and I don't want it to go back to the login screen. Thanks.
 

JOSmith99

macrumors member
May 31, 2016
37
2
I have a "Mid 2010" MacBook with OS X 10.11.5 on it. Its Energy Saver preference is set to never sleep when connected to a power adapter.

However, when I leave this MacBook alone for some time it reverts on its own back to the login screen.

How can this be prevented? I don't want the MacBook to sleep and I don't want it to go back to the login screen. Thanks.
open system preferences and go to Security & Privacy > General and uncheck Require password <time> after sleep or screen saver begins. Also, if your mac does not sleep that does not mean it does not go to screen saver. If you want to disable screensaver then in system preferences go to Desktop & Screen Saver > Screen Saver and change Start After to Never. I recommend you do allow your mac to sleep when plugged in because even plugged in using power can cause wear and tear on the battery, and the screen is the biggest power hog on most computers.
 

desertman

macrumors 6502a
Original poster
Jul 14, 2008
673
28
Arizona, USA
My issue is not about the screen saver (which I never use). It's about - unwanted - reverting to the login screen.
 
Last edited:

JOSmith99

macrumors member
May 31, 2016
37
2
My issue is not about the screen saver (which I never use). It's about - unwanted - reverting to the login screen.
Yes I know. However, by default the MacBook will sleep before the screensaver appears, so if you only disable sleeping, the screensaver will turn on which will also lock the computer and go to the login screen, so if you don't want to disable auto-lock, you need to disable both sleep and screensaver.
 

desertman

macrumors 6502a
Original poster
Jul 14, 2008
673
28
Arizona, USA
As I said before I don't use any screen saver which means the screen saver is disabled (as well as "Require password"). It's also interesting that my Mac mini - which has exactly the same settings - never reverts to its login screen, only the MacBook does.
 

JOSmith99

macrumors member
May 31, 2016
37
2
As I said before I don't use any screen saver which means the screen saver is disabled (as well as "Require password"). It's also interesting that my Mac mini - which has exactly the same settings - never reverts to its login screen, only the MacBook does.
Try going to System Preferences > Security and Privacy, click the lock icon in the bottom left and enter your password, click advanced and if it is checked uncheck "Log out after...minutes of inactivity".
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.