MacBook running out of space on startup when editing photos stored on external

Discussion in 'Mac Basics and Help' started by synsushi, Jul 20, 2009.

  1. synsushi macrumors newbie

    Joined:
    Jul 20, 2009
    #1
    I had a bunch of photos stored on my digital camera that I wanted to upload onto my computer. Only I had a little under 2 GB of free space on my startup disk, which was not going to be enough, so I uploaded them to an iPhoto library I created on my external hard drive. The free space that Finder recognized on my startup disk dropped to around 1 GB during the time it took to upload the 1300 or so photos onto the external drive, which was slightly surprising in that it's never taken so short a time, but I restarted my computer and it went back to recognizing the right amount of free space, like it always has after restarting. Everything was working just as I expected.

    However, when I edited about 1000 of those photos in iPhoto, somehow this ate up almost all of the hard drive space on my LAPTOP, not my external drive, and restarting my computer did absolutely no good. I am literally running on 13 MB of free space as I type this.

    The photos are definitely in my external iPhoto library, not on my startup disk. I searched my startup for "IMG" (my camera names photos "img_###" to see if for some reason iPhoto was copying the pictures I edited to my laptop, but none of these new pictures came up. I even went into the files I'd accessed yesterday (it's past midnight here) to see if I could figure it out, but all the photos I clicked on were on the external disk. That iPhoto is copying the pictures I edit somewhere is the only possible solution I can think of. But whatever it is that is taking up all my free space, I can't find it.

    Meanwhile, and similarly inexplicably, the copy of Cocktail I have downloaded is telling me that I am currently using only 71% of my available disk space, which uh, has basically never been true ... Cocktail has always told me that I'm using something depressing (yet accurate) like 93% of my available disk space.

    Any suggestions? I really need those 2 gigs back :(. I'm running OS X 10.5, if that helps ...
     
  2. guydude193 macrumors 6502a

    Joined:
    May 15, 2009
    Location:
    MI
    #2
    The only thing I can think of is you're using a ton of memory while you edit the photos and the Mac's using the swap file. Although that much swap is a little too much, if that is the problem.
     
  3. WillJS macrumors 65816

    WillJS

    Joined:
    Jan 6, 2007
    #3
    OS X likes around 10GB's of free hard drive space to run without a hitch, I've read on here. Is there anything that you can store on the external that you don't need on the laptop? (other pictures, podcasts, watched videos, etc)
     
  4. rhkamra macrumors member

    Joined:
    Nov 29, 2007
    Location:
    Santa Cruz, California
    #4
    iPhoto stores all of its data in a package called "iphoto library" in your /pictures/ folder in your user folder. If you edited pictures in iphoto from an external disk, odds are it copied them in there. If you do a spotlight search it won't find your photos in the package library that iphoto users either. To check if they are stored locally, go to your local iphoto library in /pictures/ and right click (or hold down control on the keyboard and click) and choose "show package contents," this will show you all the files iphoto has stored locally. :eek: wish iphoto didn't hide the photos from the users like this. If this doesn't work try a PRAM reset which should erase your swap files, which as another user said, could be the problem.
     
  5. synsushi thread starter macrumors newbie

    Joined:
    Jul 20, 2009
    #5
    rhkamra, they're not in that library. I tried resetting the PRAM too, to no avail. But I think I've found the culprit - I ran JDiskReport to see what was using up space, and I've got an "iPhoto Library_2" file of 1.7 GB in size stored under Volumes --> LaCie Disk (my external). The problem now is that I can't actually find this "Volumes" folder. I enabled invisible items through Cocktail, but it still doesn't come up, and Finder searches do nothing.

    I assume this spare iPhoto Library file is safe to delete (it's definitely not on my external hard drive - it's not even connected anymore), but how can I find it??
     
  6. geoffreak macrumors 68020

    geoffreak

    Joined:
    Feb 8, 2008
    #6
    To get to Volumes, you need to open any window in Finder and press Command + (up arrow) to go up a directory until you get to the root. The Volumes directory should be listed there.

    Sometimes when you think you are writing files to an external, it is actually writing them to your computer. This usually happens if you are using a command line based tool (like FileZilla) to write the files and your drive becomes disconnected. You can easily tell this has occurred if you see a "2" attached to the name of the drive you you plug it in.
     
  7. synsushi thread starter macrumors newbie

    Joined:
    Jul 20, 2009
    #7
    geoffreak, I'm pretty sure that's what's happening here. However, my Volumes folder is definitely not listed in my root:

    [​IMG]

    That's where it should be, right? I couldn't see it when I enabled invisible folders, either.
     
  8. gatepc macrumors 6502

    gatepc

    Joined:
    Apr 11, 2008
    Location:
    Pittsburgh PA
    #8
    I had the same problem I forgot how I had to get to it but I think I used an external program somehow if I remember how I will re edit this post. I deleted all of the external volumes out of the internal drive ( with the externals disconnected ) and found that they where eating up 30gb's of space!!! does anyone know why the mac os messes up with this stuff? I had to go in there and manually delete the volumes folder why did I have to do that?
     
  9. boast macrumors 65816

    boast

    Joined:
    Nov 12, 2007
    Location:
    Phoenix
    #9
     
  10. synsushi thread starter macrumors newbie

    Joined:
    Jul 20, 2009
    #10
    thanks, boast!! Sure enough that did the trick.
     

Share This Page