Macbook runs and boots slow/wont fully open applications

Discussion in 'Mac Basics and Help' started by thezachinator, Aug 31, 2010.

  1. thezachinator macrumors newbie

    Joined:
    Aug 31, 2010
    #1
    I just found these forums while trying to find a fix for my mac. If anyone has any advice, that'd be great!

    Here is what happened:
    I was talking on skype. I attempted to open microsoft messenger for mac. It froze up the video on skype, but I could still hear the person I was talking to. Microsoft messenger failed to open, so I clicked okay on the error box.

    A few minutes later skype froze up and I could no longer hear or see the person I was talking to. My mac was unresponsive and I could not get anything to close so I held the power button and shut it down. I waited for a few minutes and tried to re-boot. It took a few minutes and was still trying to boot, so I went and took a shower. I came back and it was fully booted, yet running very slow. Every application I tried to open would not open fully, I had to force quit anything I tried to open. Even "Finder" wasn't responding and had to be re-launched. As it stands now, I can't stand to try to even use my Mac because it runs so slow, and will not open any applications.

    Anyone have any advice?

    Thanks
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    While there are a number of things that can cause that symptom, the most obvious is disk issues.

    If your Mac froze by coincidence, but something got screwed up on the drive in the process of forcing the reboot, then it may just be a matter of fixing the directory, depending on how bad the corruption is.

    Alternately, the physical drive could be dying; if this is the case, it's only a matter of time before it dies completely, and you're going to need to replace it.

    Most important question, regardless of what the problem is: Do you have a current backup? If not, make one right now. If you don't have a backup drive, do not turn the computer on until you have bought one, then make a backup immediately. If the drive is physically dying, it's going to come down to dumb luck whether you have enough time to run a backup before it fails completely.

    Once you've done that, boot the computer from either the install disc it came with or the most recent OS install disc you have (insert the disc and power on the computer holding down the C key). Select Disk Utility from the menus.

    Select your hard drive and look down at the very bottom where it gives information about the disk; where it says "S.M.A.R.T. Status"; if it says anything other than "Verified" your hard drive is dying. If it says "Verified" it might still be dying, but it's not a sure thing.

    Assuming not, click the "repair disk" button; see if it comes up with any errors, and if so if it's able to fix them. If it finds and fixes stuff, try the computer and see if it works now. If it can't fix it, you may just have severe disk corruption or the drive could be failing; time to try restoring from your backup and see if that fixes it.

    If you don't get any errors, the next thing to try is running the Hardware Test disc that came with the computer (probably on the same disc as the installer, but you hold down the D key at boot). See if it finds any issues.

    And if all that comes up clean, report back and maybe other people will have suggestions.
     
  3. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #3
    Boot into Single-User Mode and run /sbin/fsck -fy . Run this program until it says nothing has been modified. If the program comes back it had to modify something, run the command again.

    To boot back into normal mode just type the command: reboot

    The fsck command is file system check. It is an BSD program to try to repair a borked up hard drive.
     
  4. thezachinator thread starter macrumors newbie

    Joined:
    Aug 31, 2010
    #4
    Thank you both for your replys.

    As for the first, I don't have the install disc. I ordered it online and it will be here in the next 2 weeks. I'm going to try that once it gets in.

    To the second post:
    I tried exaclty what you said, it ran throough everything and told me diskos2 invalid node structure. Then it said it was trying to repair.. As it stands now it's still running and try to reboot.

    I also tried restarting and I managed to get into disk utility. It said the same thing (diskos2 invalid node structure) and suggested I use the install disc.

    Any ideas what all this means? Thanks again!
     

Share This Page