MacBook Skips First Character Typed

Discussion in 'MacBook' started by snail17, Apr 10, 2009.

  1. snail17 macrumors newbie

    Apr 10, 2009
    White MacBook, Mac OS X v10.5.6

    Hi, I bought my girlfriend a white MacBook in October 2008 and it has been great... except for one thing.

    When typing text it often skips the first character typed. This happens in URL address bars, searches, web forms etc. which can be really annoying.
    The only 3rd party software installed is Firefox 3, which is the application that has this problem the most, but then it is also by far the most used software.

    I found 'firmware update 1.0 for MacBook keyboard (Feb 2008)' on the Apple download site which is supposed to fix this very issue. I tried to install it but was told that the MacBook was already at this firmware level (not surprising I suppose since it was bought 6 months after the update had been released).

    I have seen quite a few issues posted about MacBook Pros re: the keyboard skipping random characters, but this is just the first character typed. It happens too often for it to be a user problem.

    Does anybody else have this issue, and more importantly has anyone been able to fix it?
  2. r.j.s Moderator emeritus


    Mar 7, 2007
    I used to have the issue, but it hasn't happened in a VERY long time. I'm not sure what fixed it.

    White Late 2006 MB, OS X 10.5.6
  3. KoolStar macrumors demi-god


    Oct 16, 2006
    I would suggest trying to reset all systems, pmu, nvram, etc.
  4. snail17 thread starter macrumors newbie

    Apr 10, 2009
    So... is there anything I should know about resetting a MacBook's NVRAM/PRAM/PMU. I assume I will lose some settings (mouse speed, speaker volume etc.). Are there any other implications/risks? Thanks.

Share This Page