Macbook sound not working

Discussion in 'macOS' started by a cat *miaow*, Jul 11, 2009.

  1. a cat *miaow* macrumors regular

    Joined:
    Jun 12, 2007
    #1
    Hi,
    My sound has completely quit working. In the sound system prefs I get a massage saying "No output devices found".
    If I press the volums button keys the onscreen display comes up but has a 'no access' icon on it (a circle with a line through it).
    The icon in the toolbar has also vanished and there's just a blank space in its place.

    Oddly whatever happened also seems to have effected my ability to view Flash movies -*the will play for a few seconds an then pause –*they don't stutter they just pause.

    I think that whatever the issue is it was caused by a force shut down. All my applications were hanging so I had to press down the power button for a few seconds. Since then nothing!

    This also effects the start-up sound which I don't get and all users of the machine are the same so it's not a case of deleting users prefs.

    So far I reinstalled the latest system using combo updater, run disk utility to repair disk/privilages (from start up disk) and zapped the PRAM.

    I've looked around various forums for the last two days so please no links to google! :)

    Thanks for any help
     
  2. appleguy123 macrumors 603

    appleguy123

    Joined:
    Apr 1, 2009
    Location:
    15 minutes in the future
    #2
    I am not sure but I think this is the 1 mac virus out there. did you download any fake codecs for porn(not accusing but its a real question).
     
  3. a cat *miaow* thread starter macrumors regular

    Joined:
    Jun 12, 2007
    #3
    Thanks for your reply. But no, everything was working fine. The one thing I downloaded before this happened was an update to Skype – but I was using that for about an hour before my internet connection went down (happens alot). Then I went to play some music in itunes which was not responding, then I went to firefox which was also not responding and it's then that i forced the shut down (every app I went to had given up)

    I'll check if there's any other info about any virus
     

Share This Page