Macbook SSD Install Problem

Discussion in 'MacBook' started by krawfo, Sep 30, 2015.

  1. krawfo macrumors regular

    Joined:
    May 4, 2011
    #1
    I just replaced the HDD on my Macbook mid-2010 7.1 with a SanDisk Ultra II 2.5" 480GB SATA Revision 3.0 SSD. I created a bootable USB drive loaded with El Capitan. I powered up holding down the Option key but nothing happens. This is a machine I bought used and don't have any install disks. I inserted the Snow Leopard CD from my iMac and booted again. The only option is INSTALL OSX. When I click on the icon, nothing happens.
    Any suggestions would be most welcome.
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    You are using some kind of USB enclosure or dock to "prep and test" the drive?
    Is this correct?

    What OS is on the MacBook's internal drive right now?
    Is it 10.6.8? (that's what came on my own 2010 MacBook Pro)

    I'm going to -guess- that the problem is due to changes in how Apple's latest OS's work, particularly with the new "CORE storage" systems used in Yosemite and El Capitan.

    Hmmm... could there have been a firmware update for that model of MacBook?
    That could be holding things up.

    Just wondering -- how do you know the drive you created is "bootable" if you can't actually BOOT from it?
    OK, if the installation went ok, it -should- be bootable, but the proof is in the pudding, so they say.

    More thoughts:
    Have you tried actually swapping out the drives yet?
    The process isn't that difficult (you NEED THE RIGHT TOOLS), and will take only a few minutes.
    Then try booting the SSD actually -inside- the Mac.

    If it won't boot either way, then perhaps it might be a firmware update issue.

    The "farthest" I've taken my own 2010 MBPro is 10.8.5 Mountain Lion. That boots and runs fine, although I still use 10.6.8 as my "main OS". it just runs cleanly and boots up in five seconds flat.
     
  3. krawfo thread starter macrumors regular

    Joined:
    May 4, 2011
    #3
    Fishrrman, thanks for the response. Between posting and now, I solved the problem. I reinstalled the original HDD and upgraded to El Capitan. I then cloned the drive to an external HDD, reinstalled the SSD and transferred everything to the SSD. Everything works great.
     

Share This Page