Macbook startup issues after El Capitan update

Discussion in 'Mac Basics and Help' started by bruschetta1, Apr 11, 2016.

  1. bruschetta1 macrumors newbie

    Joined:
    Apr 11, 2016
    #1
    Hi, everyone.

    This morning I downloaded the update to El Capitan hoping for some bug fixes, but now I'm unable to boot up my computer. Here's the issue and what I've tried:

    • Download iOS - successful
    • Install iOS (black screen with apple logo) - Successful
    • Boot up computer (gray screen with my name/photo) - Failure; stays stuck around 75% loaded
    After a lot of googling, it sounded like the problem was some .kext files, but I'm unable to delete them. I've booted up holding shift, command+r, and command+control+r+p. The only options I'm given are restore from backup (I would rather not do this because my last backup was 3 weeks ago), reinstall iOS (I've done this already), get help online, and disk utility. I've run first aid in disk utility but nothing really needed repairing, it seems. What I've read says that I need to get into Finder, but I don't know how to from where I am. My harddrive is also encrypted (thanks, work) if that changes anything.

    I am able to get into the terminal and found instructions for deleting kext files that way, but I'm getting a message that the code I type in "is a directory."

    Any suggestions? I may be completely off-base with the kext thing, but that's the only solution I was able to find.
     
  2. chscag macrumors 68000

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #2
    You downloaded an update to OS X not iOS. iOS is the operating system used on mobile devices, OS X is the operating system used on your Mac. To your problem: Download and install the El Capitan combo update to see if that resolves the problem. And... stay out of the terminal as that will only make matters worse. Especially do not mess with kext files.
     
  3. boast macrumors 65816

    boast

    Joined:
    Nov 12, 2007
    Location:
    Phoenix
    #3
    Do the following:

    and tell us where it gets stuck at.
     
  4. bruschetta1 thread starter macrumors newbie

    Joined:
    Apr 11, 2016
    #4
    Sorry for the mixup (ios vs osx). It's been a long day.

    It doesn't get stuck on the initial screen. It's after I put in my password and try to login that things get jammed up.

    This may be a stupid question, but how do I download and install the combo update if I can't boot up my computer? Do I need to download it on another device and save it to an external drive?
     
  5. richard2, Apr 12, 2016
    Last edited: Apr 12, 2016

    richard2 macrumors regular

    richard2

    Joined:
    Oct 21, 2010
    Location:
    England, United Kingdom
    #5
    Is FileVault enabled on your boot volume? If so, then you must quickly press command-V after entering your password.
     
  6. ApfelKuchen macrumors 68020

    Joined:
    Aug 28, 2012
    Location:
    Between the coasts
    #6
    Considering when your startup hangs, this could be an issue with your user account data/configuration, rather than the OS.

    You said you updated OS X - did you already have El Capitan installed and working prior to the update, or did you update from an older version of OS X (Snow Leopard, Lion, Yosemite, etc.)?

    Don't bother with the combo update at this point.

    Don't try to delete kexts! Kexts are essential to the operating system - perhaps you do have one bad kext, but the solution isn't to delete them all. Deleting kexts is a form of brain surgery - deleting all kexts is the equivalent of decapitation.

    You said you tried booting to Safe Mode (holding Shift). What happened when you tried that? https://support.apple.com/HT201262

    Try to login using a different user account (even Guest). What happens?
     

Share This Page