MacBook stopped recognizing power adapter

Discussion in 'MacBook' started by dacreativeguy, Dec 14, 2008.

  1. dacreativeguy macrumors 68000

    Joined:
    Jan 27, 2007
    #1
    I just swapped my 1 week old al macbook for a new one at the apple store yesterday. Wondering if anyone has experienced something like this.

    A few days after purchase, the light on the magsafe adapter stopped lighting up when I plugged it into the macbook. The battery meter in the menu bar still showed that the computer was running off the battery, so it didn't charge. I tried this adapter on another macbook and it worked fine. I tried the other computer's adapter in this computer and it didn't light up or charge either. Definitely not a software problem because the computer wouldn't recognize the power whether it was on or off. Tried an SMC reset and it didn't help either.

    The thing I find interesting is that Apple just released an SMC firmware update a few days ago that fixed magsafe issues. I tried to install that firmware after I realized there was a problem, but since the computer no longer recognized the power source, the firmware updater would not allow me to do the upgrade.

    I'm just wondering if the new firmware would have prevented this problem and I just missed getting it installed. The apple store genius replaced the machine without too much trouble so all is well. I scoured the web and can't find anyone complaining about the problem I had.
     
  2. VSMacOne macrumors 601

    VSMacOne

    Joined:
    Oct 18, 2008
    #2
    It was probably a hardware issue, and the software update wouldn't have done any good...
     
  3. J@ffa macrumors 6502a

    J@ffa

    Joined:
    Jul 21, 2002
    Location:
    Behind you!
    #3
    Don't bother mucking about. You've proved the adapter works fine, so make a beeline for the Apple store and get it replaced. If you do so quickly, you'll be fine - on the other hand, if you wait even a couple of weeks or longer they'll be more likely to want to try and repair it. This sounds very much like a hardware issue.
     
  4. ChristineJai macrumors newbie

    Joined:
    Jan 14, 2009
    #4
    dacreativeguy,

    Same thing happened to me. I have aluminum MacBook that I bought about 2 months ago. Apple replaced my logic board with one that had the SMC 1.2 and EFI 1.3 firmware updates.

    However, today it is happening again. I was running on battery and battery drained to about 6% power level and popup warning said need to charge battery. When I plugged in the power adapter, light is dim green on mag safe connector and doesn't recognize power adapter. I reset SMC and no help. Back to the Apple Genius. What a bummer.
     

Share This Page