Macbook stuck at Grey Screen with Apple Logo and Spinning Gear

Discussion in 'MacBook' started by timrhancock, Jan 27, 2013.

  1. timrhancock macrumors newbie

    Jun 30, 2009

    My Macbook (2009 aluminium unibody (Leopard 10.5.8)) won't boot. When I try to start it up it gives the chime and then gets stuck at the grey screen with the Apple logo and some spinning gear below. I have tried booting with the install DVD and repairing through Disk Utility but this doesn't work. Disk Utility can see the hard drive but none of the partitions on it! This makes me think the hard drive has died.

    However, I can still boot to Windows through BootCamp. From Windows 7 I can still see and access files from the Mac partition. So maybe the hard drive is ok and something else needs fixing... SATA cable???

    Other info:

    The night before this happened my computer froze when trying to shut down from Windows and I had to force shut down.

    The current internal hard drive is only about 4 months old (a bit short for it to be dying already - its a Western Digital 750gb 7200rpm). I replaced the old one as it had stopped working (at least i thought it was the hard drive ). The hard drive I replaced had lasted about 2 years (Seagate 500gb 7200rpm). Maybe the 7200rpm gets too hot?

    Any help much appreciated as I really don't want to be reinstalling again.

  2. rabidz7 macrumors 65816


    Jun 24, 2012
    If you can boot windows the drive has not failed! But the mac partition might corrupted. When did you install windows? You might have deleted mac osx.
  3. Giuly macrumors 68040


    Have you clicked Activate at the top to mount the hard drive? The partitions should appear afterwards.
  4. timrhancock, Jan 27, 2013
    Last edited: Jan 27, 2013

    timrhancock thread starter macrumors newbie

    Jun 30, 2009
    Well that's good news...ish. I installed windows with the new hard drive - about 4 months ago and have used both systems quite a bit with no problems until now. I don't see how I could have deleted the Mac volume (I can still see the Mac partition in Windows - it's still there!!!). Any ideas as to why it may have corrupted?

    Another note: when I boot into windows now I get a message from MacDrive saying:

    "Mac volume may be damaged"

    I've tried this. Neither the Mac partition (nor the Windows partition) of the hard drive can be seen in Disk Utility - only the whole drive itself. Any option to repair is greyed out.
  5. timrhancock thread starter macrumors newbie

    Jun 30, 2009
    Just tried this. Can't see any Activate button but the Mount button is greyed out. The options it gives me with the drive are as if I had just installed it. All I can do is format it and create new partitions. The old ones have gone.
  6. timrhancock thread starter macrumors newbie

    Jun 30, 2009

Share This Page